Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a new customer that has send me a WordPress project. So to install the project it in my local machine, I have created a virtual host like the one below in my machine. So I can access like this http://barraquete/index.php to the content.

<VirtualHost *:80>
  ServerName barraquete

  SetEnv MYAPP_ENV dev

  DocumentRoot /home/tirengarfio/workspace/barraquete/archivos
  <Directory /home/tirengarfio/workspace/barraquete/archivos>
      # Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      #Order allow,deny
      #allow from all
      Require all granted
      <IfModule mod_mime.c>
          Addtype font/truetype .ttf
          AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css font/opentype font/truetype
      </IfModule>
      <IfModule mod_rewrite.c>
          Options -MultiViews

          RewriteEngine On
          #RewriteBase /path/to/app
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteRule ^ index.php [QSA,L]
      </IfModule>
      <IfModule mod_expires.c>
          ExpiresActive On
      ExpiresDefault "access plus 10 days"
      ExpiresByType text/css "access plus 1 week"
      ExpiresByType text/plain "access plus 1 month"
      ExpiresByType image/gif "access plus 1 month"
      ExpiresByType image/png "access plus 1 month"
      ExpiresByType image/jpeg "access plus 1 month"
      ExpiresByType application/x-javascript "access plus 1 month"
      ExpiresByType application/javascript "access plus 1 week"
      ExpiresByType application/x-icon "access plus 1 year"
      </IfModule>
    </Directory>
</VirtualHost>

When I load the index.php I get the content of the page, but the .css files are not loaded..

These are the kind of URLs:

http://localhost:8888/barra-web/wp-content/themes/enfold/css/base.css?ver=1

So what should I do to get the themes correctly?

share|improve this question
    
set the site url properly from backend->general config –  Jobin Jose Jan 7 at 10:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.