Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I asked this at superuser but I'm having no joy there. I was really hoping someone could help because I'm stumped.

I use a MacBook Pro running Mac OS X 10.6.4

For a few years I have used MAMP to test websites locally but suddenly and for no apparent reason when I start the MAMP servers the mysql light stays red.

I'm not very clued up on how to actually run a server which is the main reason I use MAMP. I also have Sequel Pro installed for administering my databases. When I try to connect to mysql in Sequel Pro through a socket connection it says

The socket file could not be found in any common location. Please supply the correct socket location.

and then

MySQL said: Can't connect to local MySQL server through socket 'tmp/mysql.sock' (2)

I can connect and access all my databases if I connect with host 127.0.0.1 but I used to just connect through the socket and all was fine. Also all my testing sites which I hosted locally are no longer being processed by PHP.

I have no idea why this suddenly stopped working and any light someone could shine on the matter would be very much appreciated. A solution even more so.

Thanks.

share|improve this question
    
I think this question is best answered on superuser as you suggest. –  Zayne S Halsall Nov 18 '10 at 10:15
    
@Zayne Me too but no-one seems to want to help. It is related to websites so I don't think it's completely off topic for PW though. Is it the title that's putting people off from answering? –  MrMisterMan Nov 18 '10 at 10:26
    
Do you have skype running? If I recall correctly this blocks port 80 and causes errors with MAMP. I know this is the case on Windows with WAMP. –  mar10 Nov 18 '10 at 11:24
    
Skye blocks ports 80 - this will bring troubles with apache but not with MySQL –  Ilian Iliev Nov 18 '10 at 11:34
    
Thanks @Zayne I'm away from my laptop until this evening but I will be investigating what you have said. Many thanks again. –  MrMisterMan Nov 18 '10 at 12:05
show 4 more comments

closed as off topic by John Conde Nov 18 '10 at 12:51

Questions on Webmasters Stack Exchange are expected to relate to webmastering within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Just to make sure .... disable all the start ups and reinstall MAMP.... Go to services and try to enable mysql from there...

share|improve this answer
    
I'm sorry, what do you mean by go to services, where are services? I have MAMP not MAMP Pro if that is a pro thing. –  MrMisterMan Nov 18 '10 at 12:29
    
No no, I am not so much familier with MAC, but same problem happened to me in windows and did above mentioned things which solved the problems, sevices are the service control panel of your OS. Try googling how to enable a service in MAC –  Starx Nov 18 '10 at 12:32
add comment

I'd see if Skype is blocking your port. I've had similar problems in the past and found if Skype is open before I launch my server, it won't launch properly. IF Skype is the culprit, simply close Skype, launch your server, and then open Skype once your server is online.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.