Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have created a WordPress blog and inserted an image with map and some links inside, but I can't open any link by pressing on the page using any browser except Google Chrome.

This is the code:

<img class="aligncenter" alt="" src="http://pretesti.ge/wp-content/uploads/2013/09/Untitled-2-copy.png" usemap="imgmap2013948720" align="center" />
<p style="text-align: center;">
<map id="imgmap2013948720" name="imgmap2013948720">
<area title="" alt="" coords="5,4,167,167" shape="rect" href="http://pretesti.ge/?page_id=14" target="_blank" />
<area title="" alt="" coords="174,6,336,165" shape="rect" href="http://pretesti.ge/?page_id=16" target="_blank" />
<area title="" alt="" coords="345,5,506,167" shape="rect" href="http://pretesti.ge/?page_id=18" target="_blank" />
<area title="" alt="" coords="514,5,678,169" shape="rect" href="http://pretesti.ge/?page_id=20" target="_blank" />
<!-- Created by Online Image Map Editor (http://www.maschek.hu/imagemap/index) -->
</map>
</p>
share|improve this question

closed as off-topic by w3d, Stephen Ostermiller Sep 10 '13 at 9:34

  • This question does not appear to be about webmastering within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
i cant insert the code. can you help? it just wont show :( –  Gio Sep 10 '13 at 7:12
    
Questions about problems with your code should be asked at StackOverflow. They are off-topic here. –  Stephen Ostermiller Sep 10 '13 at 9:35

1 Answer 1

up vote 1 down vote accepted

You are missing a hash (#) symbol at the start of the usemap attribute:

usemap="#imgmap2013948720"

(No need to enclose the map element in a p. The map element itself is non-visual.)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.