Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I set up a subdomain, and GA is showing traffic of the subdomain.

However, going into Content section, GA is not showing pageviews of the pages of the subdomain. Instead, GA lumps all the pageviews in the subdomain.

I checked the code of subdomain pages, and they're all the same as the subdomain homepage.

Am I missing a dot somewhere?

<script type='text/javascript'>try {
 var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-xxxxxxx-85']);
 _gaq.push(['_setDomainName', 'domain.org']); 
 _gaq.push(['_setAllowAnchor', true]); 
 _gaq.push(['_trackPageview', '/?scid=a2412a40-1b66-4e0a-a1d5-f5b260de6ee8']);
 _gaq.push(['b._setAccount', 'UA-xxxxxxx-56']);
 _gaq.push(['b._setDomainName', 'domain.org']);
 _gaq.push(['b._trackPageview']);
 } catch (err) {}
 (function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
 })();
 </script>
share|improve this question
add comment

1 Answer

(Without knowing the purpose behind having two accounts in your tracking code...)

Am I missing a dot somewhere?

In the past, it was suggested by Google to use a dot before the domain when including subdomains (i.e., .domain.org), however this is no longer advised as can be seen here (under Traditional (ga.js) syntax), since the dot causes cookie resets, as covered here (under number 2).

GA is not showing pageviews of the pages of the subdomain. Instead, GA lumps all the pageviews in the subdomain.

This is because Google categorizes subdomains as internal links to the root domain, as covered here, and by default does not show the domain or subdomain in reports.

To solve this using one profile, create a filter as covered here:

  1. In the View (Profile) Settings page, click the Add Filter link.

  2. Choose Add New Filter and provide the filter a name.

  3. Choose Custom filter and select Advanced on the Filter Type settings.

  4. Under Advanced settings:

    a. FieldA should be set to Hostname
    b. FieldB should be set to Request URI

  5. Set the values for both Field A and Field B to (.*), which is an expression that captures all characters.

  6. Set the Output To --> Constructor option to Request URI and provide $A1$B1 as the value for that choice.

enter image description here


Alternatively, you can add another profile to Google Analytics for the subdomain, and create a filter to show only traffic for the subdomain:

Admin -> Profiles -> Filters -> New Filter

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.