Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

if I try to redirect any page on a certain domain to one specific page (SEO does not matter, here), this ends in a loop - but I don't get why:

RewriteCond %{HTTP_HOST} ^domain.com$ [NC]
RewriteCond %{REQUEST_URI} !^/page\.html$ [NC]
RewriteRule ^(.*)$ http://domain.com/page.html [R=302,L]

I am able to use the same page in a positive second condition:

RewriteCond %{HTTP_HOST} ^domain.com$ [NC]
RewriteCond %{REQUEST_URI} ^/page\.html$ [NC]
RewriteRule ^(.*)$ http_://_domain.com/other-page.html [R=302,L]

Please, enlighten me. TIA

Complete .htaccess file added ("myedit"s and "Custom redirects" are mine):

AddDefaultCharset utf-8
# myedit: added default charset

##
# @package      Joomla
# @copyright    Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
# @license      GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

# myedit: added (though probably not necessary, here)
Options -Indexes

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

<IfModule mod_rewrite.c>
## Mod_rewrite in use.
RewriteEngine On

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##
# myedit: moved up from below "Custom redirects"; may not be needed
#RewriteBase /

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.

# Kill www
RewriteCond %{HTTP_HOST} ^www.domain1\.com$ [NC]
RewriteRule (.*) http://domain1.com/$1 [R=301,L]
RewriteCond %{HTTP_HOST} ^www.domain2\.de$ [NC]
RewriteRule (.*) http://domain2.com/$1 [R=301,L]
# Should be faster, but nogo - strange, IfModule does work
#<If "req('Host') == 'www.domain2.com'">
# Redirect / http://domain2.com/
#</If>
# More general rule, If we _wanted_ www - does "http_host - www" exist?
#RewriteCond %{HTTP_HOST} !^www\.
#RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

# Get the right page for domain2.com
#RewriteCond %{HTTP_HOST} ^domain2\.com$ [NC]
#RewriteRule ^(.*)/page\.html$ /other-page.html [L]
RewriteCond %{HTTP_HOST} ^domain2\.com$ [NC]
RewriteCond %{REQUEST_URI} !^/page\.html$ [NC]
RewriteRule ^(.*)$ http://domain.de/page.html [R=302,L]

# Redirect /+ to google+
#Redirect 301 /+ https://plus.google.com/u/0/id-here/about

# Shortlink for google maps
#RewriteRule ^$ http://goo.gl/maps/short-url-here [R,L]

# ErrorDocument - nogo, needs joomla extension?
#ErrorDocument 404 /404.html

#
## End - Custom redirects

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.
</IfModule>
share|improve this question
    
In the first example you have ! on the 2nd line, while on the 2nd example you have no ! i.e !^/page\.html$ [NC] vs ^/page\.html$ [NC] –  bybe Aug 11 '13 at 23:07
    
The first block of code you have posted does not result in a loop!? There would seem to be something else that is causing this? –  w3d Aug 12 '13 at 0:00
    
@bybe Right, that was intentional. I only want to get the first example working - the second one was just for testing purposes using the same URI. –  kamome Aug 12 '13 at 0:37
    
@w3d Thanks, but what else could cause this? It's a joomla installation hosted at mittwald.de. All my custom rules are as follows: RewriteCond %{HTTP_HOST} ^www\.domain1\.com$ [NC] RewriteRule (.*) domain1.com/$1 [R=301,L] RewriteCond %{HTTP_HOST} ^www\.domain2\.com$ [NC] RewriteRule (.*) domain2.com/$1 [R=301,L] RewriteCond %{HTTP_HOST} ^domain2.com$ [NC] RewriteCond %{REQUEST_URI} !^/page\.html$ [NC] RewriteRule ^(.*)$ domain2.com/page.html [R=302,L] –  kamome Aug 12 '13 at 0:44
    
@kamome Have you RewriteBase directive inside your .htaccess file? –  freedev Aug 12 '13 at 2:34
show 11 more comments

1 Answer

Looking at your rewrite I see a little typo, the dot in page\.html should not be escaped, since this is not a regular expression, but only the destination URL. This is the correct RewriteRule:

RewriteRule ^(.*)$ http://domain.com/page.html [R=302,L]

This could be the reason why RewriteCond %{REQUEST_URI} !^/page\.html$ [NC] doesn't match.

On the other hand, the easiest way I can suggest to solve this problem is enable RewriteLog with a sufficient high level and check it.

Update

Please pay attention if you've RewriteBase URL-path defined. RewriteBase directive will remove the defined URL-path from %{REQUEST_URI}.

For example assume your request path is /page.html and into .htaccess file you have RewriteBase /, then %{REQUEST_URI} will contain only page.html. To be clear, RewriteCond %{REQUEST_URI} !^/page\.html$ [NC] cannot match because the leading slash is missing.

Removed. Thanks to @w3d for the comment. I understood that RewriteBase affects only the RewriteRule pattern part.

Update 2

I have created a dummy virtual host with rewritelog enabled to test the given .htaccess file. Everything works well if the page.html file exist. But if the file not exist:

[... omissis ...]
(3) [perdir /var/www/] applying pattern '^(.*)$' to uri 'page.html'
(4) [perdir /var/www/] RewriteCond: input='domain2.com' pattern='^domain2\\.com$' [NC] => matched
(4) [perdir /var/www/] RewriteCond: input='/page.html' pattern='!^/page\\.html$' [NC] => not-matched
[... omissis ...]
RewriteCond: input='/var/www/page.html' pattern='!-f' => matched
RewriteCond: input='/var/www/page.html' pattern='!-d' => matched
rewrite 'page.html' -> 'index.php'
trying to replace prefix /var/www/ with /
(5) strip matching prefix: /var/www/index.php -> index.php
(4) add subst prefix: index.php -> /index.php
(1) [perdir /var/www/] internal redirect with /index.php [INTERNAL REDIRECT]
(4) [perdir /var/www/] RewriteCond: input='domain2.com' pattern='^domain2\\.com$' [NC] => matched
(4) [perdir /var/www/] RewriteCond: input='/index.php' pattern='!^/page\\.html$' [NC] => matched
(2) [perdir /var/www/] rewrite 'index.php' -> 'http://domain.de/page.html'
(2) [perdir /var/www/] explicitly forcing redirect with http://domain.de/page.html
(1) [perdir /var/www/] escaping http://domain.de/page.html for redirect
(1) [perdir /var/www/] redirect to http://domain.de/page.html [REDIRECT/302]

It seems that page.html will be replaced by index.php before the internal redirect. Then the internal redirect execute again the .htaccess file. During this new execution the request URL is changed into index.php and the redirect will be triggered as expected. This should explain why you have a redirect loop.

share|improve this answer
    
Whilst the escaped dot in the RewriteRule substitution is unnecessary and should be avoided for readability, it is not actually invalid and makes no difference to the running of the script. –  w3d Aug 11 '13 at 23:33
    
@freedev, thanks, but that was actually a typo in the post - I don't have that Backslash in the destination, anymore ;) And thanks for the pointer to RewriteLog - but that only results in an error 500 (shared hosting, perhaps not allowed?). –  kamome Aug 12 '13 at 0:27
    
@kamome RewriteLog is available only in the following contexts: server config, virtual host; i.e. you cannot use it inside .htaccess file –  freedev Aug 12 '13 at 2:29
    
@freedev That explains that, then. Thank you. –  kamome Aug 12 '13 at 2:46
    
@freedev: You seem to be mistaken, RewriteBase does not affect the value of the %{REQUEST_URI} variable - this always contains the full path component of the requested URI. The value of RewriteBase effects relative path substitutions in the RewriteRule. –  w3d Aug 14 '13 at 8:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.