Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a website with httpd (front end) and Apache tomcat (back end).

I'm trying to install Google Sitemap Generator and create sitemap for the website.

I followed the following link for installation:

http://googlesitemapgenerator.googlecode.com/svn/trunk/doc/gsg-installation.html

But I'm not able to load http://server:8181, it is showing a blank page.

My system details are:
CentOS release 5.4 (Final)
httpd-2.2.3-65.el5.centos
apache-tomcat-6.0.37

I'm using mod_jk connectors for connecting Apache and Tomcat. Here is my mod_jk configurations:

cat /etc/httpd/conf.d/mod_jk.conf
JkWorkersFile /etc/httpd/conf.d/workers.properties
JkLogFile /var/log/httpd/mod_jk.log
JkLogLevel info
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
JkRequestLogFormat "%w %V %T"
JkMount /* worker1
JkShmFile  /etc/httpd/logs/jk-runtime-status

This is my worker.properties file:

cat /etc/httpd/conf.d/workers.properties
workers.tomcat_home=/usr/share/apache-tomcat-6.0.37/
workers.java_home=/usr/java/default
ps=/
worker.list=worker1
worker.default.port=8009
worker.default.host=localhost
worker.default.type=ajp13

I have installed Google Sitemap Generator and gave me final result. Google Sitemap Generator daemon successfully started. To start the Google Sitemap Generator module in Apache, you must restart Apache. After you restart Apache, you can go to http://<this-server-address>:8181/ to configure the application. Google Sitemap Generator (Beta) was successfully installed.

But the problem is I can not access mydomain:8181.

Is it necessary to configure ssl? if I give mydomain.com:8181 it is redirecting to mydomain.com. I have no idea why.

If I use Lynx from command line. lynx http://domain.com:8181 gives a blank page.

share|improve this question
    
Are there any messages in the the apache log files that would shed some additional light on the situation? –  Stephen Ostermiller Jul 25 '13 at 13:52
    
@Stephen Ostermiller: Unfortunately there is no error logs. The thing is if I give domain.com:8181 apache is forwarding it to tomcat. is there anyway to prevent this? is there anyway to prevent the forwarding of http on port 8181 only? in mod_jk.conf? –  Randeep Jul 26 '13 at 4:11
add comment

2 Answers

up vote 0 down vote accepted

You should be able unmount mod_jk in your virtual host settings for port 8181.

<VirtualHost *:8181>
    ServerName www.example.com
    ....
    JkUnMount  / NameOfJkMountGoesHere
    ....
</VirtualHost>

I would also suggest looking into using mod_proxy to forward your requests to Tomcat. I run Tomcat as http on port 8080 and my front end Apache connects to it over HTTP using mod_proxy. This is a much simpler setup (and protocol) than mod_jk. I put the mod_proxy settings directly in each virtual host so that they only apply to the specific site that I want to forward to tomcat.

share|improve this answer
    
JkUnMount / NameOfJkMountGoesHere worked for me. Thanks a lot. –  Randeep Jul 26 '13 at 17:46
add comment

It could be a firewall setting. I recently had problems accessing a port where I was trying to run a service because my firewall was disallowing it.

share|improve this answer
    
its not firewall settings problem. I can telnet to port 8181 from other servers using public ips. –  Randeep Jul 26 '13 at 4:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.