Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I bought a domain without webspace and want to forward emails to that domain to my Gmail account. But I don't receive any emails which are send there, not even a return-to-sender-email. I also tried with another email provider and my company's email address.

My hoster supports email forwarding, thus I activated it with the "catch all" option and added my 3 email addresses as target. The domain is configured with www IN CNAME example.rhcloud.com. There is no other configuration yet.

Do I need to add MX entries? Or what else do I need to do?

P.S.: Don't migrate this question to serverfault. They said I'm not allowed to ask questions, because I'm not a sysadmin...

share|improve this question
    
My hoster is profihost.com, but their support doesn't seem to be able to answer such questions. –  Chris Jul 16 '13 at 17:07
    
A "catch all" email account with forwarding should receive all incoming email and forward it to your target email addresses. If email service is included with your hosting package, the support team there should be able to view mailserver logs to see what's happening with your emails. If you comment or update the question with your domain, your DNS table records will provide some more info, and a test email can be sent to your mailserver to see what response code is received. –  dan Jul 17 '13 at 4:00
add comment

2 Answers 2

up vote 2 down vote accepted

You will need to add an MX record to your domains DNS. If you're using your Registrar to do the email forwarding, you'll add their e-mail servers for the MX records. Without an MX record, mail servers have no idea which servers to send the mail to.

share|improve this answer
    
+1 This is the right answer. Checking OP's DNS records it is clear that there are problems with the current MX settings. –  Tom Brossman Jul 17 '13 at 8:47
    
I already tried with several mx records, but didn't succeed. The problem occured because my hoster OpenShift uses dynamic IPs and therefore I have to use a CNAME, which won't allow MX records. –  Chris Jul 17 '13 at 9:44
add comment

Email Forwarding works only if your First Email ID is working perfect. Then according to Setting, Email is Forwarded to Second Email ID.

To enable you Mail Service, you do not need Webspace or any hosting package. Just login to Domain Control Panel and then update some Name Records their.

Google, Microsoft and some other Mail Service Provider Free Email Services for Custom Domain. For Managing google does better task but it is paid. While Microsoft Handles Full Controls to User but is Free for 500 users and best service with All Microsoft Products without Limitations.

For Google Mail Service for your own Domain:

sign up here: https://www.google.com/a/signup/?enterprise_product=GOOGLE.EDU&hl=en&source=gafe-homepage-canvas-en This is education edition from Google which allow 10 users Free. You can choose other Paid also.

Then Login to your Domain Control Panel and update records as described in Support:http://support.google.com/a/bin/answer.py?hl=en&answer=140034

For Microsoft Mail or Windows Live Mail Service:

sign up here: https://domains.live.com/Signup/SignupDomain.aspx

And change Records as shown in Domain Control Panel. Then you will find your Mail Working within 6-12 hours of span.

Good Luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.