Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have recently added my website to Google, and I don't understand why he adds useless parameters to my URLs.

Normal URL:

build/view/2/akali/mid

Google URL:

build/view/2/akali/mid?role=adc

That's boring because the parameter role take the value adc instead of mid.

How can I do to avoid this?

share|improve this question
add comment

2 Answers

Google doesn't add parameter to URL alone. Googlebot follows links and display URL it finds.

Search on your webpages and links from other websites. Then, correct these links if you don't want Google displays them.

share|improve this answer
    
All urls are correct on the website. Look at google.com/… –  gaetanm Jul 14 '13 at 19:21
    
Maybe you have backlinks with incorrect parameters. Look at your JavaScript code also. Remember Googlebot saves links it finds. –  Zistoloen Jul 14 '13 at 19:32
    
Checked all links, also in js scripts. No way. :( –  gaetanm Jul 14 '13 at 19:58
    
Did you check links from external websites? –  Zistoloen Jul 14 '13 at 20:04
2  
I think I have found the solution: Google Webmaster Tools -> URL Parameters -> edit -> No URLs. –  gaetanm Jul 14 '13 at 21:36
show 3 more comments
up vote 0 down vote accepted

In addition to change the option on Google Webmaster Tool (URL Parameters -> edit -> No URLs), don't forget to use the canonical tag to help Google to erase the bad pages indexed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.