Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I recently started a new project with a newly registered generic tld domain.

As soon as Google started indexing the page, it displayed a "translate this page" in SERP's, which tries to translate the page to the language of a small Eastern European country from the language that the site actually uses.

I tried everything to prevent this: language meta headers and attributes, localisation through Google Webmaster Tools...all to no avail - nothing helped.

After a couple of weeks I spotted dozens of inbound links popping up in Google Webmaster Tools all coming from that small Eastern European country, from sub-pages that are not active anymore (either sending out 404's or 301's to the main page), and also had been written in that other language. So the domain had been registered before and as it looks, it did got a lot of possibly spam links in that language.

I can't even ask the sites where those links should have been to remove them as they are not active anymore physically, just in Google Webmaster Tools and/or internal data masses...

Now I'm at a loss about what to do?

As my site is pretty new, it does not have many links pointing towards it in my targeted language. So those are probably not enough to convince Google of attaching the right language to it as Google ignores all other signals about the page language.

I'm also unsure if I should use the "disavow" tool, or a reconsideration request...or what else to do about this miserable state. I never used these tools before so I don't have any experience with them.

Somehow I have to convince Google about the right language of the page and also to not count/apply/whatever all those historical links from the previous owner. (The domain had been deleted without any traces in Google before I registered it)

Has anyone here ever dealt with a similar "Translate this page" problem?

(I've also looked at this thread: How can I prevent Google mistakenly offering to translate a page? but didn't find a solution there)

share|improve this question
    
"...translate the page to the language of a small Eastern European country..." - The language that it translates to should be based on your language/locale settings? You can get the "translate this page" suggestion even when just a small fraction of the page is not in your target language (or is unrecognisable as being in your target language). –  w3d Jun 16 '13 at 18:12
    
Hi w3d, thanks for your comment. Google tries to translate the page from that wrongly detected language into the locale language the page is targeting. If I try the "translate this page" link, not one word is translated, as all words are already in the locale language. Google just mistakes the page language because of those links. (The translate this page url has a sl ("source language"?) param for the wrongly applied language and a hl param for the targeted language). The language of the page is clearly recognisable. The wrong signal is coming from those inbound links in the wrong language. –  crnm Jun 17 '13 at 8:46
add comment

2 Answers

According to this Google Translate support doc, you should use:

<meta name="google" value="notranslate">

Then in Google Webmaster Tools, make sure you select an English speaking country that matches your site's locale for "Geographic target" under:

Configuration -> Settings

You can also request links displaying in your SERP be removed by demoting them under:

Configuration -> Sitelinks

Finally, increase the frequencies specified in your sitemap and resubmit it to Google.

Assuming that you're not using a ccLTD from that other country, or an IP address located in that region, Google should re-index your site accordingly after some time.

share|improve this answer
    
Hi Dan, thanks for your answer. I'm already using the notranslate meta information as well as using geo targeting in wmt (and also all other kinds of signals about the language). I don't have any problems with subpages of my site, just the homepage gets the "translate this page" information all the time.The 404s are not on my site but on those sites where - according to googles wmt - I'm getting the links in the wrong language from. Those come from 404 pages. But nothing changed in over three month now. –  crnm Jun 14 '13 at 6:24
    
Just for clarity: you're getting the "translate..." message when clicking on the indexed link for your home page in the SERP? And have you submitted a sitemap with last lastmod and changefreq specified? –  dan Jun 14 '13 at 6:43
    
Hi Dan, yes, next to the the serp listing url I get a "translate this page" link from Google. I've submitted a sitemap as well (not using lastmod and changefreq) and Google has indexed the new content in my targeted language. If I click the "Translate this page" link Google is not translating the page (probably because of the notranslate meta information - before I used the meta, Google tried to translate it but actually did not translate anything as the site is in the targeted language already). So this "Translate this page" is coming from all those wrong language inbound links, I'm sure. –  crnm Jun 14 '13 at 9:04
    
Without the URL, I'd only be guessing at this point. I would suggest updating the sitemap with lastmod and changefreq, and ask for more help in a Google Translate group (maybe for Developers). –  dan Jun 14 '13 at 9:28
add comment

Here is a similar question http://productforums.google.com/forum/#!searchin/webmasters/ortodox.info/webmasters/Ir0_EQvxpDY/9eBLwG8dC-IJ, no answer from Google.

Google does not use the meta language tags for language detection and meta notranslate currently is used for Chrome browser, to prevent the translate option appearing at the top of the page when you already accessed a foreign language site (This page is in... Would you like to translate it?).

Try to add more text in your language, on the homepage.

share|improve this answer
    
Hi NR03, thank you for your answer. I've spotted some similar questions here on Stackexchange as well as in Googles product forums but haven't found a sufficient answer here or there. There is a lot of text in my language on the homepage and Google is finding this text as well if I search for an exact phrase. I'm not pleased with adding more text as I write the text for the visitors, not for a search engine and I think the text as it is is good for those visitors. Therefor I would rather concentrate on telling Google not to count those wrong language links. I'm just unsure how to do that :( –  crnm Jun 23 '13 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.