Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a Wordpress blog. In Google Webmaster Tools, I found mutiple "not found pages" like this from feed: kart-postal/k-imam-zaman/feed/.

How can I add noindex to feed and why I get not found page?

share|improve this question

1 Answer 1

This problem often occurs with Wordpress websites.

You get "not found pages" (404) because Googlebot find some links on the source code of your website. Wordpress in particular add some links for feeds in the <head> section even if you don't want. You can see these links by displaying the source code of your webpages (CTRL + U with Google Chrome, Mozilla Firefox or Internet Explorer).

The best option is not to put a noindex in these "not found pages" but remove links pointing to these webpages. In order to remove these links from your source code and fix this problem, you can install a SEO plugin for Wordpress like Wordpress SEO by Yoast. This plugin allow you to remove these links. After installing the plugin, go to admin panel here: SEO => Titles and Metas and check the four checkboxes in Clean up the <head> part.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.