Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am having trouble with Google Rich Snippets, on the verification authorship, I am getting this error:

Email verification has not established authorship for this webpage.

Email address on the mrnepal.com domain has been verified on this profile: Yes Public contributor-to link from Google+ profile to mrnepal.com: Yes

Automatically detected author name on webpage: Not Found.

How to fix this error?

share|improve this question
    
What is your email address? something@mrnepal.com? Does the email have to be something@blog.mrnepal.com? –  Lord Loh. Sep 28 '13 at 8:05
add comment

4 Answers

I had the exact same issue. It's really fiddly. I had several errors I needed to fix.

  1. My first problem was that my posts were not showing up as "Mat Ellis" (my Google Profile name) but as my Wordpress user ID "matellis". I had to change my "Full Name" to match my Google Profile settings. See the screencap.

  2. My second problem was that I was confusing Publisher-ship and Authorship, and so I was using a Google Page as my link instead of my profile. You can see the difference between my page and my profile.

  3. The next thing was an error in the Google docs. It doesn't explain you have to add ?rel=author to your Profile link. I also added this to the a tag. So my link went from:

    <a href="//plus.google.com/113473027594498160821?psrc=3">
    

    to:

    <a href="//plus.google.com/113473027594498160821?rel=author" rel="author">
    

    Doing these three things got my structured data test to work fine, see this example.

The whole process was time consuming and frustrating, made worse by Wordpress.com seeming complete lack of interest in any up-to-date SEO tools. I hope this is helpful.

share|improve this answer
    
This is a different community Mat, the reputation you have there will not work here. I have over 30000 points there but it does not give me authority to use my privileges here. –  Starx May 20 '13 at 6:19
    
Was my answer any help? –  Mat E. May 20 '13 at 17:16
    
Very helpful information, But I was already aware of these. –  Starx May 21 '13 at 1:05
add comment

Now your byline goes like this:

Written by Nabin Nepal

Change it to this:

Written by Nabin Nepal (Starx)

This way the name corresponds to the name on your Google+ profile.

See this: https://plus.google.com/authorship

Make sure your byline name matches the name on your Google+ profile.

share|improve this answer
    
Same problem. Check here. I had tried this earlier too. –  Starx May 14 '13 at 0:30
    
Starx is my nickname, not by original name. Google give priority to original name, isn't it? –  Starx May 14 '13 at 0:31
add comment

Kindly follow these steps to get it worked fine: http://blog.kissmetrics.com/google-authorship/

Checkout this image of source code:

I think, you might have added this code from word (copy paste) so " will not fetch properly in HTML. Just edit it and url reference will start pointing your google profile.

enter image description here

share|improve this answer
    
Unfortunately this is not helpful. I have already done all the needed steps. –  Starx May 10 '13 at 10:02
    
Have you tested your page in Google rich snippet testing tool? –  PeggyP May 10 '13 at 10:25
1  
You may have not done it correctly, i did view source of your url menepal and could not find author tag mentioned below: <a href="https(://)plus.google.com/109412257237874861202? rel=author">Google</a> here you need to replace url with your profile url. –  PeggyP May 10 '13 at 10:39
1  
I think i got the issue, when i tried to check your author url by viewing source it seems that the " " are not properly placed. Try to click that link, it will point to wrong url. Kindly fix it and see !! it may work. –  PeggyP May 13 '13 at 6:42
2  
I have just added image showing wrong reference URL in source code due to wrong placement of " ". –  PeggyP May 15 '13 at 10:08
show 6 more comments

PeggyP is right. There exist two quote symbols, and some word-processing apps use to mess them up. The equivalent for " (and right one) is " (see two perfectly vertical comas). But you've misspelled it in your metatag and you've used the other one (the wrong one), which looks like an italique " (two oblique comas). Have a care look to the quote symbol in your link rel author metatag as shown in PeggyP picture. I've also made this error tons of times. You can compare the quotes in your other metatags, as they are correct. It's only wrong in your rel=author metatag line.

Your current line (wrong):

link rel=”author” href=”https://plus.google.com/100940214614580829424/posts

The one you should have:

link rel="author" href="https://plus.google.com/100940214614580829424/posts"

share|improve this answer
    
That is my recent attempt by using a plugin called author box. It was not working before too. –  Starx May 17 '13 at 2:35
    
Does the plugin use those kind of quotes? May it be you the one when using the plugin? –  Giuseppe May 17 '13 at 2:43
    
What if I remove that line? I think there is an option to do that. –  Starx May 17 '13 at 2:54
    
It may be a good idea to try it (removing it). You've got it duplicated 9 lines later (at Yoast plugin) with the root url (not the /posts one) –  Giuseppe May 17 '13 at 3:03
    
The current link in your author metatag points me to a 404: blog.mrnepal.com/%E2%80%9Dhttps:/plus.google.com/… --> No problem on removing it. I've also read in google forums and in google support about the "written by" fixing it, which you have (though mixed in code with some html elements). Have you tried pointing your profile to your "About" page? (currently it points to your blog home page) –  Giuseppe May 17 '13 at 3:38
show 1 more comment

protected by Community Oct 12 '13 at 16:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.