Webmasters Stack Exchange is a question and answer site for pro webmasters. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've found many a common question but unfortunately none of them really directly answered my inquiry, below is a copy paste of the info I am provided by xname.org I've replaced my .com with blah.com, my email with blah.yahoo.com, and my IP address with

    $TTL 86400 ; Default TTL
    blah.com.       IN  SOA ns0.xname.org.  blah.yahoo.com. (
                    2013042110  ; serial
                    10800   ; Refresh period
                    3600    ; Retry interval
                    604800  ; Expire time
                    10800   ; Negative caching TTL

    $ORIGIN blah.com.
                IN      NS      ns1.xname.org.
                IN      NS      ns0.xname.org.
                IN      NS      ns2.xname.org.
                IN      MX  10  blah.com.
    blah.com.           IN      A

    www.            IN      CNAME       blah.com.

So blah.com works but www.blah.com doesn't. I initially tried to put just plain www for the cname, but found some reference to adding the trailing dot to it. The other uncertainty I have is whether the blah.com in "x in cname blah.com" should have its trailing dot or not.

I know this should be obvious, and perhaps even easy but I cannot find an answer to this anywhere, I did find some solutions suggesting I put www.blah.com as an A listing pointing to my IP but if I can help it I'd prefer only have my IP listed once as it's a dynamic IP and the fewer places I need to update it when it changes the better.

share|improve this question
You've added the domain.com. with the dot on the end which is fine but as far I I'm lend to believe there should be no dot after www have you tried removing it? – Simon Hayter Apr 21 '13 at 18:23
Yes, my initial setup didn't have the dot after the www and still would not resolve for http://www.blah.com/ – Varyl Apr 21 '13 at 18:25
When you DIG or NSLOOKUP www.blah.com, what is returned? Is it possible it is resolving to the correct IP but the webserver isn't responding to that alias? – Mere Development Apr 21 '13 at 21:43
So when I try to resolve the ip of blah.com it works, but www.blah.com it doesn't.. – Varyl Apr 22 '13 at 0:46
up vote 0 down vote accepted

So I finally managed to resolve this after playing with many things, what finally did it was adding:

                IN      MX  10  www.blah.com.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.