Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Following this blog post I set up Wordpress on an EC2 instance. I've pointed A records to my Amazon EC Elastic IP Address.

After propagation, when I open my website with the domain name, it works. But when I click on other page, it just redirects me to my IP address instead.

share|improve this question

migrated from superuser.com Apr 21 '13 at 12:52

This question came from our site for computer enthusiasts and power users.

    
How is your web site and web server set up? We're missing too many details to be able to answer this. What operating system, what web server, what kind of website are you running? How is it configured? –  slhck Apr 20 '13 at 9:43
    
I've set-up website on "console.aws.amazon.com" and got elastic IP after setting, my domain answersmine.com set "A" name records. After propogate, home page open corectly but not others associate page –  Sanjeev Apr 20 '13 at 10:32
    
We already know that. What web server do you run and how did you configure your home page? For example, do you use Apache and virtual hosts? –  slhck Apr 20 '13 at 10:32
    
Thanks for reply. I'm new and did myself. that's why not ask with incomplete question. I've set-up as per one tutorials "iampuneet.com/wordpress-amazon-ec2/"; and add "A record" into my DNS. Really I need help. –  Sanjeev Apr 21 '13 at 9:55

1 Answer 1

This could be caused by the settings you are using in WordPress.

When you first install WordPress it remembers the host name you used to run the installer, and uses that.

Log in to your WordPress admin panel, go to Settings > General in the menu.

Check that the fields for both 'WordPress Address (URL)' and 'Site Address (URL)' have the correct site address that you want to use.

share|improve this answer
    
Its work now. Thanks... One more problem here. permalink structure is not working, is any command/or plugin from that I can fix permalink problem. –  user27318 Apr 22 '13 at 10:05
    
That problem is a little more difficult to figure out without more information. What I would do is deactivate any plugins you have and try it again. if the permalinks work that way you can enable the plugins one-by-one until you find the one that's causing the problem. If I was able to help you solve your original problem you can mark my answer as the 'accepted answer' by clicking the check mark beside it. –  Sherwin Flight Apr 22 '13 at 14:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.