Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I've read the FAQ and searched the help center. My URL is http://www.etechsupport.us.com.

I have also done 301 redirect of no-www to www.

But www is not being indexed by Google and no-www is. My SEO guy wants with www.

I researched and found my URL is subdomain to us.com domain but my site is unique.

I want all pages to be indexed as www and not as no-www.

What is the best option to do this?

share|improve this question
add comment

1 Answer 1

The problem is that you have not waited enough time for Google to apply the URL changes. As you can see here your site is indexed however the changes are not reflecting yet.... changing URL names can take months, Google will most likely be aware of your changes but is waiting to see if the change is intended. So there's nothing more you have to do other than wait. The important thing is site visitors are not effected.

share|improve this answer
    
Thanks @bybe. But my question is why Google treats etechsupport.us.com as SubDomain? Most of the options are disabled in GWT with the message "Restricted to top level domains only". –  Ojal Suthar Apr 17 '13 at 10:31
    
Add the site with www. in GWT. –  bybe Apr 17 '13 at 11:03
    
@Ojal: That's because it is a subdomain of us.com, which is owned by the company that sells the subdomains, CentralNic Ltd. It's not a top-level domain, although it looks confusingly like one. The actual ccTLD for the United States is just .us. –  Ilmari Karonen May 16 '13 at 15:02
    
@Ilmari Karonen: Thanks. The problem was resolved using HTTP 301 redirects of etechsupport.us.com to www.etechsupport.us.com –  Ojal Suthar May 17 '13 at 16:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.