Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

This question already has an answer here:

My site is geocology.ca.

About a year ago I attempted to add geocology.ca to Google's search index by following the steps for 'Moving Your Site' in Google's Webmaster Tools, transferring from my old site at hughstimson.com.

Everything seemed to go fine.

  • I submitted a sitemap for the new site, and it was read successfully.

  • I added a robots.txt file with a single entry ALLOWing all user agents, and it quickly showed up in Webmaster Tools, properly registered.

  • When I go to Google Webmaster tools there are no errors and no complaints.

BUT: my site never appeared in Google's search results. At all. Searching for site:geocology.ca produced no results.

After a couple of months I added a small wordpress blog in a sub-domain, as a sandbox for a client. That blog quickly showed up in Google's index, and now if you search for site:geocology.ca the content of that (fake) blog is all that will appear.

Does anyone know how I can address this? Is there perhaps a way to completely reset Google's knowledge about my site and start again?

share|improve this question
add comment

marked as duplicate by bybe, Su', John Conde Apr 12 '13 at 2:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 3 down vote accepted

Its not indexing because you're instructing not too...

Remove this from your pages:

<meta name='robots' content='noindex,nofollow' />

Fix this in WordPress:

  1. Login to Administration Dashboard
  2. Click Settings > Privacy > (Ensure that indexing is allowed,If WordPress is set to have search engines index the site, then check your theme's header.php)
share|improve this answer
    
thank you for the tip in WP :) –  toughskin Apr 12 '13 at 0:24
    
Thank you, that resolved it. Settings > Privacy wasn't present in my Wordpress admin, but Settings > reading > Discourage search engines from indexing this site was checked for some reason. Unchecking it removed the meta tag. The site hasn't appeared in Google yet, but I trust it will now. –  Hugh Stimson Apr 12 '13 at 23:23
    
give it 1-2 weeks and bam! posting something in the blog may speed up the process. –  bybe Apr 12 '13 at 23:31
    
Yup, it's working now. Thanks again. –  Hugh Stimson May 6 '13 at 23:52
    
Awesome, Thanks for letting us how you got on.. ;) –  bybe May 7 '13 at 0:06
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.