Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am trying to set up seamless authentication on windows for my intranet site, using SSPI on Apache 2.2 and windows 2008 server. I have installed mod_auth_sspi.so in apache/bin. I have also added the webpage url to the intranet zone in IE and Firefox. I am using Perl and CGI.pm for my site and retrieving the username using the CGI Env variable Remote_User and Auth_User. Neither of these are set and nor does the authentication seem to be happening as

I do not get a pop-up window in both IE or Firefox or any local html file i tested with.

My config on httpd.conf is as follows.

<IfModule !mod_auth_sspi.c>
    LoadModule sspi_auth_module modules/mod_auth_sspi.so
</IfModule>

<Location "C:/Program Files (x86)/Apache Software Foundation/Apache2.2/htdocs/TestWeb/">
    Options FollowSymLinks
    Order allow,deny
    Allow from all
    AuthName "TestWeb"
    AuthType SSPI 
    SSPIAuth On 
    SSPIAuthoritative On 
    SSPIOfferBasic on
    Require valid-user 
    SSPIDomain domain
</Location>

I am not sure if my domain name is the issue here. My corporate domain is in the format corp.company.com I used that and he ip associated with it with no luck. I retrieved my domain name by issuing the NET VIEW /DOMAIN on my windows server and it listed my corp domain, which is what i would like to authenticate the users with.

share|improve this question
    
Got it working for me by adding ExecCGI to the FollowSymLinks notation. –  Suzun Apr 3 '13 at 18:54
    
Can you please add exactly what you did as an answer and then accept it, as the method used. This way we don't have have 100's of questions of opened that are resolved :P –  bybe Apr 4 '13 at 13:08

1 Answer 1

up vote 0 down vote accepted

Options FollowSymLinks ExecCGI Added this since my actual code was in another folder to which I had a symlink to the actual location. Hope this helps someone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.