Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am using sendgrid SMTP Server to send the e-mails from my java web application. The issue is the any e-mail containing external links to a one website and images are going to spam.

If i remove the images and links of the website, Emails will land in INBOX.

This happens only when email contains links to a website (http://www.mysite.com), Links to this website are causing spam.

What is the work around for this.

When i test for spam score using http://spamcheck.postmarkapp.com/

I got the below result :

 0.0 RCVD_IN_DNSWL_NONE     RBL: Sender listed at http://www.dnswl.org/, no
                            trust
                            [74.63.236.162 listed in list.dnswl.org]
 0.0 HTML_MESSAGE           BODY: HTML included in message
 0.1 DKIM_SIGNED            Message has a DKIM or DK signature, not necessarily valid
 0.0 T_DKIM_INVALID         DKIM-Signature header exists but is not valid
share|improve this question
    
Have you tried to reduce the image size and test it? –  Seda Zeynep Miranoglu Mar 25 '13 at 12:50
    
How many emails are you sending out? Since sending to Hotmail, Gmail all have triggers for spam on 'mass emailing' and things like images. –  bybe Mar 25 '13 at 13:34
    
I have observed that emails having links to (mysite.com) are landing in spam, But links to any website are working fine. –  Vinay Mar 26 '13 at 3:49
    
please see my EDIT –  Vinay Mar 26 '13 at 6:30

1 Answer 1

There are a few things that I would assume is causing your email to land in the spam box. Since your question is short on the details of the email, I will answer it as best as a I can based on assumptions.

Also I've used SendGrid successfully in the past, good service!

These are not in order of importance!

  1. The first to look for is the ratio of 'Text' to 'Images'. 2 lines of text for every image. Image size file size can affect this also. Send grid recommends that you only use images if you have to.

  2. Provide a text only version of your email.

  3. Make sure there are no spam triggering words
    http://blog.mannixmarketing.com/spam-trigger-words/

  4. Make sure your DKIM, SPF, Sender-ID and Domain Keys Are Setup Properly

  5. If you are having issues with maybe one website link causing the spam issue, try using a url shortener.

I bet if you just go through these 4 or 5 things, your emails will start showing up in the Inbox!

a sendgrid blog post

Good Luck.

share|improve this answer
    
Yes, I am having issue with only links of one website. But remaining links are fine –  Vinay Mar 26 '13 at 3:51
    
One more thing I am successfully sending emails with the same links using Gmail, It works fine, all the e-mails are landing in INBOX, But when i use the sendgrid, All the emails will land in SPAM, What is the exact cause for thi. –  Vinay Mar 26 '13 at 4:08
    
Are you adding a text-only version to the email? –  JoeyH Mar 26 '13 at 15:51
    
yes, I have added. Earlier it was missing.I added it now –  Vinay Mar 27 '13 at 4:50
    
please refer this post –  Vinay Mar 27 '13 at 5:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.