Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have been using Firebug for several years, and I don't know if it's an option I have activated by mistake, or it's a new feature. When I want to see the HTML structure of a web page and I click on an HTML tag to see the style options, a grey pop-up opens with a link to http://www.w3.org/XXX. The link may be useful, but this panel is quite annoying because it covers almost all of the styles panel and part of the web view. I have been trying to find how to disable it in Google and firebug wiki, but I can't find the option as I don't know how is it called. Does anybody know where to disable it?

I'm using Firebug 1.11.2 with Firefox 19.0.2 in Linux (Debian)

Thanks in advance

share|improve this question
    
I just tried Firebug 1.11.2 for FireFox on Linux. I was able to right click on a page and select "Inspect Element with Firebug". I could see the html structure without the gray box that you are describing. Once you are in the HTML tab, there are several options available by clicking on the arrow in the tab, have you tried all of them? –  Stephen Ostermiller Mar 19 '13 at 11:00
    
Thanks for replying. I tried checking and unchecking all checkboxes in the arrow next to HTML tab, and it's still there. I'm using Firebug 1.11.2 in Linux too, with Firefox 19.0.2. I can see HTML structure doing the same you did, that box appears when I click any HTML tag in that structure with the mouse, or when I put the mouse over an HTML tag in the structure shown. –  cmmata Mar 19 '13 at 11:16
1  
The "Show Quick Info Box" setting is the only one that causes a gray box to be shown on mouse over of the html tree for me. It has information about the element, and not the link to w3.org though. You should try firebug with a fresh profile. On the command line use firefox -no-remote -ProfileManager, create a new profile, install firebug, and try that. It could be some cruft in your firefox profile that is getting in the way. –  Stephen Ostermiller Mar 19 '13 at 11:29
    
That works! Thank you! Now I see the same link but in a small tooltip next to the HTML tag. No covering now. If you want, copy that solution answering the question and I'll mark it as good solution. Thanks again! –  cmmata Mar 19 '13 at 12:13

1 Answer 1

up vote 1 down vote accepted

There is something in your Firefox profile or Firebug install that is corrupt, or preventing Firebug from working correctly.

You can get firebug working by installing it into a fresh profile. On the command line use firefox -no-remote -ProfileManager to create a new profile, then install firebug.

If you want to migrate your bookmarks, saved password, or other information to this new profile and make it your default, then follow these instructions from Firefox help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.