Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I already worked a lot with wampserver but it's the first time i have a problem with it.

After I downloaded it wanted to create a database in phpmyadmin, and then it says:

"Forbidden. You don't have permission to access /phpmyadmin/ on this server."

Can somebody help me because this is really strange and I need a database for my program ^^.

share|improve this question
add comment

migrated from stackoverflow.com Mar 18 '13 at 9:32

This question came from our site for professional and enthusiast programmers.

2 Answers

It could be a number of things but it is probably that apache is Listening on the W8 IPV6 default localhost address which is ::1

  1. edit httpd.conf, using the link on the wampserver icon wampserver -> apache -> https.conf find the line > Listen 80 and change to > listen 0.0.0.0:80

This will force apache to listen on IPV4 and make the pre-configured phpMyAdmin security configuration compatable.

By default phpMyAdmin has the following access restriction: Order Deny,Allow Deny from all Allow from 127.0.0.1

IP Address 127.0.0.1 is the IPv4 address for localhost

You may also need to make sure your HOSTS file has the line

127.0.0.1 localhost

uncommented to 127.0.0.1 localhost or add it if it does not exists.

The hosts file is protected by windows, in order to save it you must have Administrator privilages. Vista/W7/W8 you may think you are an Administrator BUT YOU ARE NOT.

To successfully save the hosts file do this to launch your editor with Admin Privilages.

Locate your editors icon on the desktop or from the Start menus ( notepad will do if you have nothing else ) left click + shift over your chosen editor icon - will show a menu. select "Run As Administrator" from the menu. Navigate your editor to the c:\windows\system32\drivers\etc\hosts file.

When you have made changes you will now be allowed to save them.

share|improve this answer
    
I did step 1 correctly, In my HOSTS there are 4 time "127.0.0.1 localhost" and 1 time "::1 localhost" Is that normal? I just dont get the step to save it. Do i need to make a shortcut or just cut the HOSTS file out and paste it on my desktop? –  user2164811 Mar 18 '13 at 9:47
add comment

Your phpmyadmin configuration file contents in wamp alias folder must look as below:

     <Directory "c:/wamp/apps/phpmyadmin3.4.5/">
     Options Indexes FollowSymLinks MultiViews
     AllowOverride all
         Order Deny,Allow
         Allow from all
     </Directory>

Whereas it looks as this:

     <Directory "c:/wamp/apps/phpmyadmin3.4.5/">
     Options Indexes FollowSymLinks MultiViews
     AllowOverride all
         Order Deny,Allow
         Deny from all
         Allow from 127.0.0.1
     </Directory>

The same can be used to make your "sqlbuddy" and "webgrind" applications to work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.