Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I changed our companies domain name a year ago from radfan.co.uk to radfan.com. When typing radfan into Google the number one result is still radfan.co.uk rather than the .com. This is not the case for Bing and Yahoo.

This is the .htaccess rule I have used

RewriteEngine on
RewriteCond %{HTTP_HOST} ^radfan\.co\.uk$ [OR]
RewriteCond %{HTTP_HOST} ^www\.radfan\.co\.uk$
RewriteRule ^/?$ "http\:\/\/www\.radfan\.com\/" [R=301,L]

Is there something else I need to do?

UPDATE:

Turns out if I search for radfan.com google finds it but asks if I meant "radfan.co.uk" ...

UPDATE 2:

I moved the domain in January 2012, so 14 months now

share|improve this question
    
A year ago, did you notice Google your domain was changed in Google Webmaster Tools? –  Zistoloen Mar 11 '13 at 20:55
    
I didn't set up webmaster tools for the old domain as I knew it would be temporary, I did for the .com and never noticed that .co.uk was still the number 1 hit when searching for radfan. –  SimonBarker Mar 11 '13 at 21:01
    
Is the RewriteCond active on the old site? Mostly, you have separate folders for different domains on your host, you need to have this RewriteCond in the htaccess of your old domain, not the new one. –  DKOATED Mar 11 '13 at 21:07
    
How long ago did you redirect .co.uk to .com? as things like this can take a while, I've seen sites appear like this for 3 months or more. Also!! You may want to remove <head><div id="fb-root"></div></head> out of the header :P –  bybe Mar 11 '13 at 21:21
    
I moved the domain in January 2012, so 14 months now, thank for the fb-root tip - copy past error :-( –  SimonBarker Mar 11 '13 at 21:23
show 3 more comments

3 Answers 3

What you did is fine. The search results that you see may appear only to you as part of the personalized search results. This may be due to your search history settings. Here is a guide on how to disable this feature

share|improve this answer
    
Sadly I don't think this is that case as I don't have Google web history enabled on my account and running any browser in private mode still brings up the same result ... –  SimonBarker Mar 11 '13 at 21:05
add comment

Alright then, can you please try this instead:

Options +FollowSymLinks
RewriteEngine on
RewriteRule (.*) http://www.newdomain.com/$1 [R=301,L]

While replacing http://www.newdomain.com with http://www.radfan.com Also, verify that the Apache Mod-Rewrite module is enabled (just to be sure) And verify also if you still have backlinks pointing to your old domain.

share|improve this answer
    
Ok, how will I know if it's worked? Won't to google results take a few days to update?I'm fairly sure the rewrite engine is on as typing radfan.co.uk in the adress bar takes me to radfan.com. There will be some links to the old site but all of the important ones will be to the .com as the change has been for over a year. –  SimonBarker Mar 11 '13 at 21:15
    
@Mohamed Anis Dahmani: Please don't answer twice, edit your first one. –  Zistoloen Mar 11 '13 at 21:18
    
Thank you for your kind advice Zistoloen. @SimonBarker: When I search radfan I find radfan.com on first place. –  Mohamed Anis Dahmani Mar 11 '13 at 21:58
add comment

I would think that your results are localized to your country. I am in Canada and when I google "radfan", radfan.com is #2. #1 is a wikipedia entry, and there are no listings for radfan.co.uk on page one.

I am pretty sure there is nothing better you can do with your rewrite rule.

share|improve this answer
    
Great, thank you for the information –  SimonBarker Mar 16 '13 at 13:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.