Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

What you'd expect when you select a site in the IIS console and choose the "stop" button is that all bound ports would stop responding, right? That's what it did in earlier versions of IIS, at least.

What I'm seeing today (on more than one server) is that, when I stop the site, the SSL port 443 stops as expected, but port 80 stays open -- and it keeps responding to requests with 404 Not Found errors!

TCPView shows that port 80 is being used by "System service" with a PID of 0. Process Explorer does not show PID 0 using port 80.

This is IIS 7.5 on Windows Server 2008 R2 x64. Is this perhaps some fancy new feature of the Windows Firewall? (The service is running, but the firewall is disabled by Group Policy.)

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Sounds like either something is sharing the port or its failing to shut down correctly

Run a netsh http show servicestate to diagnose if anything is running on the HTTP Service.

Additionally do a netstat -ano and see if the IIS service is running on a ID. (I know you said TCPView is reporting ID:0 but this doesn't sound right and I'd put more trust in the netstat command.

If you find its still running then a simple taskkill /pid:IDNUMBERHERE should do the trick.

share|improve this answer
    
Thanks, that's it! Interestingly, netstat also shows PID 0 as the owner. But the netsh command you gave was able to list more info, including the correct process: turns out it's Microsoft's Web Deploy Remote Service, which happens to be used by the site hosted by the servers I noticed the "problem" on. –  ewall Mar 11 '13 at 20:09
    
Glad I could help ;) –  bybe Mar 11 '13 at 21:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.