Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have never experienced this type of issue before, so I don't know where to begin searching to be able to troubleshoot or fix the problem. Also, I hope this is the correct SE website for this type of question.

I launched a website last month for a friend's business and helped him set up his email, etc. The site is hosted on my turnkeyinternet.net reseller account. It is the Professional I account.

A few days ago he needed to add SSL and, obviously, a dedicated IP. The reseller account comes with 2 free dedicated IP addresses and a free OneClick SSL.

I gave him one of my dedicated IPs and the OneClick SSL. TurnKey set up both of these for me. The IP two days ago and the SSL yesterday. Today, my friend called me and told me that one of his clients was getting a bounce-back email when trying to send him an email at his domain name. His client said it first happened two days ago (the same day TurnKey set up the dedicated IP).

This was from a @hotmail.com account. I began testing and found that this issue was with all Miscrsoft affiliated addresses: Hotmail, Yahoo, Outlook, Live (and I assume any professional email addresses hosted by these services or that use these as an email client).

I confirmed with my friend AND his client that prior to the changes made by TurnKey, they were both sending and receiving each other's emails.

I contacted TurnKey and their response was: "Nothing has changed on our end as far as the mail server/DNS. It seems these providers are simply blocking email sent to the IP in question. Yahoo/hotmail are blocking the emails so it's up to them to whitelist or allow them to go through."

His website does not have a newsletter and he hasn't sent mass mail.

It is obvious to me that whatever changes TurnKey made caused this issue. They will not help me and I don't know where to begin to troubleshoot.

UPDATE

I received an email from TurnKey this morning stating, again - "This has nothing to do with any IP or SSL's being recently changed/updated/installed or otherwise."

However, my friend called me and said he tested everything again this morning and everything is working correctly with Microsoft email addresses.

This makes me wonder if TurnKey discovered their mistake, fixed it, then lied about making the mistake.

share|improve this question
    
I decided to check my domain for this issue as well... and WOW! I am having the SAME problem. I have a dedicated IP as well, but my site's SSL is from GoDaddy, not OneClick. TurnKey also set up my IP and SSL... Now I am a bit sick to my stomach... How many potential clients didn't receive my estimates when they requested them through my website?!? –  Travis Pflanz Mar 9 '13 at 1:36

2 Answers 2

up vote 1 down vote accepted

There are several steps you need to check.

Important is the IP and the right Reverse-DNS to this IP, a good tool to check it out: http://www.dnsqueries.com/en/domain_check.php

All icons in the "mail"-part should be green.

share|improve this answer
    
Thanks, Netsetter. Here are the results. Can you guide me to correcting the issues? Acceptance of domain literals (Red X "KO")- Not all of your mailservers accept mail to postmaster@[ip_address] (Literal format). RFC1123 5.2.17 require all mailservers to accept mail to this kind of address. This is a common problem and actually can be ignored. The report of the test is: Does not accept mail to postmaster@[ip_address]. –  Travis Pflanz Mar 9 '13 at 19:23
    
SPF record (Yellow Exclamation Point "Warning") You don't have a SPF record for the domain, meaning that you are not using the protection given from this kind of technology. This is only a warning, but please consider in implementing it! –  Travis Pflanz Mar 9 '13 at 19:24
    
For your first question, do you know what kind of mail server you are running? In example, with Exim, you would enable allow_domain_literals to pass this point. –  user23808 Mar 9 '13 at 22:38
    
About the SPF record, you will set this in your domain's DNS settings, here's a good link explained the SPF: nickwilsdon.com/spf-domain-records –  user23808 Mar 9 '13 at 22:41
    
I got the SPF setup... It was actually just a "Enable" button in the cPanel... Forgive my ignorance, but I don't know what kind of mailserver, how can I check? –  Travis Pflanz Mar 10 '13 at 19:42

If two separate customers of turnkey are having a problem with Microsoft emails then a blocked ip address is unlikely as you are both using dedicated ip's.

I would check your ip's against a black list checker like this one.

If nothing is showing up as blocked then it sounds like a config issue. If your hosting provider will not support you, consider changing hosting provider.

Not to up sell or anything but I run a hosting company and would never turn a customer away for support! what are you paying them for?

share|improve this answer
    
Thanks William, this is actually the one thing I did check previously and I forgot to mention. Every check comes back OK. I have also added an update to my original question. –  Travis Pflanz Mar 9 '13 at 18:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.