Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

In June 2012 I added my website (a blog that I host on my own server) to Google-Analytics. In January 2013 I decided to use Piwik instead of Google-Analytics.

So I removed my website from the Google Webmaster Tools page. I also removed the Google's script from the footer of my webpages. I checked several times that there are no links to any Google Tools (Google Fonts, Google Analytics) in my code.

However Ghostery (Add-on for Firefox) shows that Google-Analytics still tracks my website. I checked the following pages on Google: The page www.google.com/dashboard/?pli=1 (Dashboard) lists my website (logically it shouldn't as I removed my website from it) but when I click on "Manage my sites" the page www.google.com/webmasters/tools/home?hl=en&authuser=0 (Webmaster Tools - Home) my website is not listed any more and there is only a form to add a new site. The page www.google.com/analytics/ invites me to sign up and then doesn't list any website and shows a form to add a website.

Do you have any idea about what I should do to stop Google-Analytics to track my website for good? Thanks for your help.

ps) this is my first message on Stack Exchange, I hope my English is not too bad. Thanks you all for making this big community exist. Keep up the good work.


Update: Could the meta <meta name="google" content="notranslate" /> in my code be the reason of the tracking? Answer: no, it's not related.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

There is no Google analytics on your own site anymore, however your site iFrames content from vimeo.com, which contains google analytics tracking.

<iframe src="http://player.vimeo.com/video/" webkitallowfullscreen="" allowfullscreen="" frameborder="0" height="315" width="560"></iframe>

This site has GA tracking, and your plugin is detecting the tracking from that site. So your site itself won't be tracked in Google analytics*, if you absolutely want to stop any reference to analytics from your site remove the iFrame'ed content.

*The only exception being users who have a old copy of your page in their webbrowsers cache which still contains GA, this will still send a ping to the Google servers but as you disabled your site their it won't be tracked.

share|improve this answer
    
I didn't think of checking 3rd-parties on my website. Thanks very much for your help. –  Jules Mar 9 '13 at 13:24

To stop Google Analytics tracking your website, you can delete Google's script in your webpages.

Script looks like this:

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-XXXXXXXX-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

Without this script, Google can't track your website anymore.

share|improve this answer
    
I should have written it in my first message (I've updated it). I removed the Google's script from the footer of my webpages. I checked several times that there are no link to any Google Tools (Google Fonts, Google Analytics) in my code. That's why I really don't understand why Google Analytics is still interested in my website. ;-) I swear Google still tracks my website although I removed this kind of script from my code. –  Jules Mar 8 '13 at 14:42
    
Ok. It may be Ghostery (your Firefox add-on) doesn't work normally and find <meta name="google" content="notranslate"/> in your code (or something else). Try to delete the meta. Otherwise, do you always have new data in Google Analytics for your website or data look fake? Try to switch to Real-Time Reports to test in real-time. –  Zistoloen Mar 8 '13 at 15:00
    
Zistoloen thanks very much for your help. I removed the meta <meta name="google" content="notranslate"/>. I also had a look at the Ghostery Options, I ticked "Show tracker sources by default", then when I load the homepage of my website Ghostery displays: Detected tracker source URLs = http://www.google-analytics.com/ga.js So I guess my problem is unfortunately not related to the meta notranslate. –  Jules Mar 8 '13 at 15:30
    
Ok, are you sure you don't have ga.js somewhere? Give us the URL of your website for analyzing. –  Zistoloen Mar 8 '13 at 15:35
    
Sorry for the delay, it's your vimeo iframe. Try to use an other video player. Moreover, iframe is bad for SEO. –  Zistoloen Mar 8 '13 at 20:00

Hi agree that you need to remove the similar code like the one below. This can be found in the header area. If you are using Wordpress it is basically inserted under header.php.

var _gaq = _gaq || []; _gaq.push(['_setAccount', 'UA-XXXXXXXX-1']); _gaq.push(['_trackPageview']); (function() { var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); })();

If it is still working then basically there is another code in the website hidden. In Wordpress, there are a lot of themes that integrated some kind of a plug in that you just need to embed some code in the option.

  1. Check the SEO plug ins if it allows or enable analytics to track your website. You can disable it or just remove the code under it.
  2. Check the theme options if there are options in the header area that you can embed the analytics code in it.
share|improve this answer
    
Please read other answers before posting your own answer. –  Zistoloen Mar 8 '13 at 21:23
    
Thanks James but I don't use Wordpress. Zistoloen and xenox found the true problem. –  Jules Mar 9 '13 at 13:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.