Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I've moved my site from ak.net84.net to aramk.com, and I've redirected the pages from the old to the new using these methods in my htaccess for the old site:

  • all pages redirect to the new site using a rewrite rule, with 301 http code
  • manually specified redirects with 301 http code
  • removing all redirects, so all links to the old site will result in a 404 (redirects to my host's error page)

At the moment, it appears Google may be treating the sites as duplicates, so I've removed the indexed pages for the old site by using the "Blocked URLs" page in Google Webmaster.

The problem I'm having is that for my new site, Google is crawling but not indexing:

enter image description here

There are not health warnings for the new site, but there are health warnings for the old site (saying I have removed URLs). Meanwhile the old site is still being indexed:

enter image description here

The old site doesn't have a sitemap, and the robots.txt is blank. The new site does have a sitemap, but it's not being indexed:

enter image description here

At this point I've been waiting about a month without any changes while I try different settings, and I'm prepared to just delete the old site from my host completely in the hope Google will stop indexing it. Any other suggestions?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Your site is not redirecting.

ak.net84.net/ is not redirecting, and (assuming your URLs are the same as on the new site) your old pages are resulting in soft-404's.

I've removed the indexed pages for the old site by using the "Blocked URLs" page in Google Webmaster.

You don't want to block the old URLs; you want to redirect them. Otherwise Google will not see the redirects.

share|improve this answer
    
Sorry, I should have mentioned, I was redirecting the URLs before, but now I'm just allowing soft 404s. Is that a problem? The redirects weren't working before so I tried something else :\ –  Aram Kocharyan Mar 6 '13 at 0:27
    
Yes, that is a problem. Soft-404's are pages that look like 404's but return an incorrect status code (usually 200 OK). Soft-404's usually result from a misconfiguration and are rarely intentional. If you don't redirect then your new site will literally been seen as a brand-new site and will not benefit from any of the rankings from the old site and will consequently take much longer to index. –  w3d Mar 8 '13 at 11:44
    
Well, I put the 301 redirects back on the old site, and waited about 2 weeks but I'm still seeing the same lack of indexing on my new site. Are you aware of any other issues that might be taking place? Thanks. –  Aram Kocharyan Mar 23 '13 at 0:46
    
But your site is still not redirecting?? Setting up 301 redirects when you migrate to a new domain name is the primary concern - and is really the only thing you must do. You need to leave these redirects in place for as long as possible (forever ideally, but 6+ months should be OK). It takes time for Google to update its index, depending on how quickly it crawls your site... several weeks, or even months. The problem you might now face is that if Google received consecutive 404s when visiting the old URLs then it is likely to remove these from its index before it's indexed your new site. –  w3d Mar 23 '13 at 1:04
    
Thanks for the tips, I wasn't redirecting my homepage. Guess it's a waiting game for now. Cheers. –  Aram Kocharyan Mar 24 '13 at 1:59

Your robots.txt file looks really odd - you appear to have javascript trying to call a PHP file in it!! I can't imagine Google liking that....

You could also try adding "Allow: *" in there. It shouldn't be absolutely necessary, but wouldn't be a bad idea to try. Also, try referencing the non-gzipped version of your sitemap.xml file. Again, the .xml.gz should be okay, but it's worth trying.

share|improve this answer
    
An Allow: directive is not necessary. –  w3d Mar 5 '13 at 15:19
    
I mentioned that it shouldn't be necessary, but is there any reason not to try? Considering that the site still isn't being referenced after the actions OP has already tried, I'd think it's worth adding in. –  Andrew Lott Mar 5 '13 at 15:23
    
"...reason not to try?" - The default behaviour in a robots.txt file is "allow". The only time you would need to use Allow: (which isn't actually part of the standard) is to create an exception, where you Disallow: a parent folder, but wish to Allow: a subfolder. –  w3d Mar 8 '13 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.