Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I can't figure out why my tags are being indexed by google and not my actual posts. So in google, my posts are showing up as mysite.com/tags/post and I of course I want it to look like mysite.com/category/actualpost.

Any ideas what could be wrong? My domain is 3 years old and I just started a new focus of an existing site. I can't figure this out! There is no duplicate content, I have a sitemap submitted to webmaster tools and robots.txt...I have everything I need. This is the first time something like this has happened to me.

Let me know if anyone has any ideas.

share|improve this question
    
Has your question been answered or do you need more information? –  Christopher Feb 14 '11 at 19:08
add comment

5 Answers

This is very normal for the wordpress Website for this there is an option to stop this indexing of that tags and you may also stop them in the indexing by just adding them to Robot.txt file

For more Quer visit my profile and contact me

http://in.linkedin.com/in/pradeepchauhanseoexpert

share|improve this answer
add comment

Isn't this a WordPress setting? Settings > PermaLink Settings > don't use custom structure, use a date/title/ or other. Isn't it a good thing to have the category in there?

share|improve this answer
add comment

Without seeing the site I'd guess you have more links going to the tags pages, and might want to modify your internal site structure. You can add some of the posts you want to rank higher to your home page via a top posts or popular posts type plugin, you can also do some cross linking from some of your other posts that have decent backlinks via a related posts type plugin, and build external links to some of your best post content.

If your certain your post pages would rank if it weren't for your tags pages then you can add the noindex, follow meta tag to your tags pages this will keep Google from using these pages in their index but still follow the links to your post pages. Alternatively you could nofollow your tag links in the site navigation and in the post content this should remove the value your internal links are giving those pages.

I would recommend boosting your post pages over lowering your tag pages but either way should get the job done.

share|improve this answer
add comment

Try creating an XML sitemap (there are various Wordpress plugins to help with this) and setting the priority of your posts higher than the tag pages. This will tell Google that the posts are more important and they should get indexed faster and rank higher than other content.

Submit it to Google Webmaster Tools or add Sitemap: /sitemap.xml to your robots.txt file.

share|improve this answer
add comment

If you're using Wordpress 2.9 or later there should be canonical tags built in to your posts by default. You should check to see that the URLs you wish to use is actually what is being provided. If not, that's what needs to be changed. There is a plug in that will help you with this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.