Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Site is a Joomla 2.5 site. I wanted to add a non www to www redirect to the htaccess file, did so, then the redirection went mad, reversed but still the site redirects.

When i click view site in admin panel, i get linked to http://domain.comindex.php/

The website is http://www.domain.com Visiting the website URL works without www, but once you click on projects it acts mad too. Projects is managed with joomshopping extension.

EDIT: the redirect also happens when rewrite is deactivated in admin panel.

##
# @package      Joomla
# @copyright    Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
# @license      GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.


Redirect 301 /index.html /index.php
Redirect 301 /services /project
Redirect 301 /projects/projects.html /project
Redirect 301 /projects/project1.html /project
Redirect 301 /projects/project2.html /project
Redirect 301 /projects /project
Redirect 301 /keypersonnel.html /about-agrin/keystaff
Redirect 301 /cooperation.htm /about-agrin/intcoop
Redirect 301 /member.html /about-agrin/memberships
Redirect 301 /contact.html /contacts
Redirect 301 /hr.htm /jobs
Redirect 301 /index.php/404 /index.php
share|improve this question
    
added and removed a www to non www redirect, now its redirecting all to non www, but still the same error wit www. It seems changes dont get adapted properly, this is really getting exciting. –  Aurigae Feb 25 '13 at 12:14

1 Answer 1

up vote 2 down vote accepted

You have a few conflicting rules and your 301's redirects should use absolute paths since this can cause loops, as well as a un-required index.htm > index.php which is also wrong and should be a conditional rewrite. Backup your htaccess file, and use the htaccess which is used on my site that I've edited to match your site.

#Joomla Defaults
Options +FollowSymLinks
RewriteEngine On
RewriteBase /
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteRule .* index.php [F]

#Removes index.php
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
RewriteRule ^index\.php$ http://www.agrin-consult.com/ [R=301,L]

#Removes index.htm
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.htm\ HTTP/
RewriteRule ^index\.htm$ http://www.agrin-consult.com/ [R=301,L]

#Some Additional Rules
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_URI} !^/index\.php
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* index.php [L]

#Enforces WWW
RewriteCond %{HTTP_HOST} !^www\.agrin-consult\.com
RewriteRule (.*) http://www.agrin-consult.com/$1 [R=301,L]

#Removes HTTPS
RewriteCond %{HTTPS} on
RewriteRule (.*) http://%{HTTP_HOST}%{REQUEST_URI}

#Old Redirects
Redirect 301 /services http://www.agrin-consult.com/project
Redirect 301 /projects/projects.html http://www.agrin-consult.com/project
Redirect 301 /projects/project1.html http://www.agrin-consult.com/project
Redirect 301 /projects/project2.html http://www.agrin-consult.com/project
Redirect 301 /projects http://www.agrin-consult.com/project
Redirect 301 /keypersonnel.html http://www.agrin-consult.com/about-agrin/keystaff
Redirect 301 /cooperation.htm http://www.agrin-consult.com/about-agrin/intcoop
Redirect 301 /member.html http://www.agrin-consult.com/about-agrin/memberships
Redirect 301 /contact.html http://www.agrin-consult.com/contacts
Redirect 301 /hr.htm http://www.agrin-consult.com/jobs

Ensure that you have the following Settings in your control panel

  1. Login to Administrator Control Panel in Joomla
  2. Click Site Tab > Global Configuration
  3. Search Engine Friendly URLs (Yes)
  4. Use URL rewriting (Yes)
  5. Adds Suffix to URL (No)
share|improve this answer
    
have uploaded you htaccess, no changes. As it also beaves like this when i use the default htaccess where all was fine with maybe the problem is lying somewhere else? –  Aurigae Feb 25 '13 at 12:18
    
RewriteEngine On RewriteCond %{HTTP_HOST} !^(www|ftp|mail)\. [NC] RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [L,R=301] –  Aurigae Feb 25 '13 at 12:32
    
after the lines above where entered the mess started, i reversed it and now we are here. –  Aurigae Feb 25 '13 at 12:33
    
Sounds like you haven't enabled rewriting. Please see my updated answer. –  bybe Feb 25 '13 at 12:41
1  
Good to hear that you got it sorted. Please answer your own question and mark it accepted. –  bybe Feb 25 '13 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.