Sign up ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

CloudFlare seems to only cache my homepage, and I am wondering if there is a way to force it to cache all pages. Notice it when BlueHost went down today and only my homepage is cached by CloudFlare. Any thoughts?

This is the free account on a Wordpress site. However, pages have not been updated since launch.

share|improve this question
Are you using the free account or a paid level? Is your site a dynamic site (e.g. WordPress) or a static site? – JCL1178 Feb 3 '13 at 18:10
free account. dynamic Wordpress site. – kjy112 Feb 4 '13 at 12:33

4 Answers 4

up vote 1 down vote accepted

When you have a dynamic site (like WordPress) you should also activate the CloudFlare Railgun so that you get the maximum benefit out of the service. A lot of WordPress "pages" may not be cached by CloudFlare, especially if they change frequently (like an archives page). If your site falls into that category, Railgun may help you out.

share|improve this answer
Railgun only applies to BlueHost re-seller's account's main account but not the resold accounts. Is that correct? – kjy112 Feb 6 '13 at 12:50
Not sure. Railgun is enabled/disabled from CloudFlare and should work at the domain level and not be affected by the ISP. Why do you ask? – JCL1178 Feb 6 '13 at 18:11
i asked because Railgun is avilable for partners and my hosting company is one of the partners. however, there's no option to turn it "on/off" – kjy112 Feb 6 '13 at 19:00
I don't use Bluehost. These would seem to be questions better suited for their Support folks. – JCL1178 Feb 6 '13 at 19:05

That's not correct.

If you would like to extend CloudFlare's CDN to cache more than static content by default, you can use Page Rules to extend the caching capabilities to cache more content. Page Rules can be accessed by going to the settings for the domain that you want to create a Page Rule for.

If you want to cache everything on, say,, then you would want to input the URL like this ** (include the asterisks) and choose "Cache Everything" in the cache option drop down selectors.

By the way, if you have a WordPress site ~ caching everything can cause issues with admin and login sections of the site, and other logged in sessions. If you do not want to have caching function on these specific urls, then set Page Rules to exclude * and * before creating a Page Rule to cache everything.

share|improve this answer

All pages should be cached.

Go to and on the domain in question, even though it says "active", click on "edit" and make sure it is "activated". It is not by default.

Additionally, under "Advanced", you can set cache level to more or less aggressive.

share|improve this answer

You cannot force cloudflare to cache all pages. All you can do is just keep on navigating through your site. Cloudflare is automatic, as soon as people visit your site it will cache it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.