Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I've added my site to Google Webmaster Tools. The site was submitted a few weeks ago. The index status shows 0 but it shows 6 URLs have been indexed in the sitemaps section. If I search in Google I can see that the site is indexed and several pages appear:

https://www.google.co.uk/search?q=site%3Awww.medexpress.co.uk&oq=site%3Awww.medexpress.co.uk&sourceid=chrome&ie=UTF-8

My question is why is the index status 0 when the sitemap section shows several indexed pages and also the pages appear in the search engine.

share|improve this question
1  
Are you looking for reliable information regarding the number of indexed pages? –  JVerstry Aug 23 at 7:12

2 Answers 2

up vote 4 down vote accepted
+50

Sadly Google's Webmaster Tools doesn't use REALTIME DATA and is updated in intervals from a few days and sometimes I've seen some data missing for up to 2 weeks. So there's nothing to be worried about, your URLS are indexed as Google updates the rankings more often they do Webmaster Tools.

You will also find similar problems with Traffic, and Keyword Data these tend to behind from 3 days and again I've seen the data not be updated for 2 weeks a time.

share|improve this answer
    
as an aside do you think the link to my website on my above post will contribute positively to my SEO? –  DD. Jan 29 '13 at 22:28
2  
@DD. No, the link in your post will not contribute +/- to SEO since it contains a rel="nofollow" attr. As to the difference between the "Index Status" (Total indexed) and "Sitemap Indexed" figures (since they are both reported by GWT)... as bybe says, real time data is not used and these two figures report on different things. Whilst it might be correct (in your case) to show a "Total indexed" figure that matches the number indexed from the Sitemap, this is not necessarily the case, so to do so would be incorrect. The "Total indexed" figure therefore needs to be calculated independently. –  w3d Jan 29 '13 at 23:18

The URLs you have indexed have both the HTTPS and HTTP protocol in them along with www. These would be reported separately in Webmaster Tools, so if your verified site in Webmaster Tools is HTTP plus www, the sitemap count wont report on the HTTPS links and vice-versa.

As you seem to be redirecting to HTTPS, ensure you have an HTTPS version verified and a sitemap uploaded with HTTPS URLs and you will likely get more accurate data.

See the bottom of this for more information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.