Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I've made a site for a friend, and here's the url:

http://mensasana.it

Issue: There is no trace of it in google. He used to have an html site, and at least it was indexed. I changed it to a Wordpress site, and after 20 days, all results are gone. I mean, if you look for site:mensasana.it you get no results at all.

So, a few days ago I've submitted sitemap, checked that robots.txt is correct, checked with lynx browser... al is good.

I tried to add a listing in Google places, and when I have to enter the sitename, I get:

Website is incorrect http://mensasana.it/

What am I missing?

share|improve this question

closed as too localized by John Conde Jan 12 '13 at 0:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You missed... <meta name="robots" content="none" />! That's equivalent to "noindex, nofollow"! –  w3d Jan 12 '13 at 0:23
    
I think you just saved me :P –  Akmur Jan 12 '13 at 0:26
    
Must be some crazy theme option I didn't see O__o (I still don't see, I just removed the code) –  Akmur Jan 12 '13 at 0:28
add comment

Browse other questions tagged or ask your own question.