Webmasters Stack Exchange is a question and answer site for pro webmasters. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Been having a problem with XAMPP lately. Whenever I try to start up Apache, it starts then stops and displays the following error message:

Error: Apache shutdown unexpectedly.
This may be due to a blocked port, missing dependencies, 
improper privileges, a crash, or a shutdown by another method.
Check the "/xampp/apache/logs/error.log" file
and the Windows Event Viewer for more clues

When I check the error.log file, the log is mostly filled with the following errors:

[Sun Dec 02 23:32:10 2012] [error] [client] File does not exist: C:/xampp/htdocs/HNAP1
[Sun Dec 02 23:32:10 2012] [error] [client] no acceptable variant: C:/xampp/apache/error/HTTP_NOT_FOUND.html.var
[Sun Dec 02 23:32:13 2012] [error] [client] File does not exist: C:/xampp/htdocs/TEADevInfo
[Sun Dec 02 23:32:16 2012] [error] [client] client denied by server configuration: C:/xampp/htdocs/xampp/

(I'm using XAMPP 1.8.1, with control panel v3.

This has really had me scratching my head for quite some time now. Any help would be appreciated!

share|improve this question

closed as off topic by Su', paulmorriss Jan 10 '13 at 11:46

Questions on Webmasters Stack Exchange are expected to relate to webmastering within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Are you using SSL? Have you tried to Fix this error by updating the configuration to force close the SSL service?

If you edit the file httpd.conf at /xampp/Apache/conf and comment out the line:

#LoadModule ssl_module modules/mod_ssl.so

Try to Start Apache again and see if it worked.

The source of this issue can occasionally be another service listening on port 443.

Hope that helps!

share|improve this answer
Unfortunately, I tried this and I still got the same error :( – user1421521 Jan 10 '13 at 7:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.