Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Over the last month, the home page of my website hosted on Media Temple's grid server and has been appearing in google listings as an https website. I have never requested or needed the extra security of ssl and as such have not purchased a secure certificate. I have submitted a xml google site map for the site and added a .htaccess redirect to the correct http file. I am at a loss as to why this is happening.
Any advice would be much appreciated.

share|improve this question

migrated from serverfault.com Oct 19 '10 at 10:14

This question came from our site for system and network administrators.

    
You might find posting this on webmasters.stackexchange.com advantageous –  cometbill Oct 19 '10 at 9:09

3 Answers 3

To override this use canonical URLs to tell Google to use the non https version in their search results.

share|improve this answer

Mu understanding (from a similar issue I saw last year) is that if Google detects the same content available on the same domain over SSL secured https as http, they will prefer the SSL version in their index. I have not seen a preference to set to override this.

The best solution for you is to get https turned OFF for your domain. If you don't have a certificate this is the best way to handle it anyway. Once the https protocol is shut off, google should correctly link the pages with the http protocol in their index.

share|improve this answer

It is likely that a site somewhere linked to you using https:// and Google then followed relative links through your site which ended up as HTTPS. You've take some good steps already by putting the correct URLs in your XML sitemap. I would also suggest to:

  • Turn off SSL if possible.
  • Link to your pages using the full URL, i.e. http://example.com/page.html instead of /page.html. If it's too much effort to do the whole site, at least do the menu so it shows up on every page.
  • Use canonical URLs, at least on your most popular pages.
  • Find out who is linking to you and check they are not using HTTPS. Contact them and ask to be linked in the correct way.
share|improve this answer
    
Wohooo happy 3k day! –  Mark Henderson Oct 21 '10 at 4:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.