Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I cannot for the life of me get keyword insertion in my destination URLs to work. I want to have the keyword appear in the destination URL. I've tried turning off autotagging, and have tried all of the following as destination URLs:

www.myhomepage.com/?keyword={keyword}
www.myhomepage.com/?keyword={keyword:defaulttext}
www.myhomepage.com/index.php?keyword={keyword}
www.myhomepage.com/index.php?keyword={keyword:defaulttext}

In each case, my ad has been approved, and then I've clicked on it myself. In each case, clicking on the ad takes me to www.myhomepage.com. Any parameters are obliterated. Weirdly, "index.php" is also obliterated.

I tried emailing AdWords support and they didn't reply. I tried calling them, but the person I spoke to had very limited technical knowledge and wasn't any help.

Does anyone know what I'm doing wrong/or if it's possible to do what I want?

share|improve this question
    
Those all should work. Any chance you have destination URLs set at the keyword level? Those will overrule the URLs set at the ad level. –  Eric Brandel Jan 4 '13 at 3:43
    
@EricBrandel: Maybe this is it, I'm not sure. My marketing company does the AdWords for me, so I'm not very competent with it. However, I worked out that the destination URLs I was setting were not being used. So maybe what you are suggesting is what's happening. I'll see if I can find out. Thanks. –  Andrew Jan 4 '13 at 19:35
    
@EricBrandel: BTW, do you know if I need auto-tagging disabled to get the above destination URLs to work? –  Andrew Jan 4 '13 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.