Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I can't figure it why I can't open files (photos as a start) that contain utf-8 characters in their file name.

For example, I have the following photo: José-Antonio.jpg , the browser outputs it as Jos%C3%A9-Antonio.jpg but trying to access it, will return an 404 error code.

I tried and have these settings in my /etc/httpd/conf/httpd.conf but don't seem to fix it:

#AddDefaultCharset UTF-8
AddDefaultCharSet ISO-8859-1

IndexOptions FancyIndexing VersionSort NameWidth=* HTMLTable Charset=UTF-8

Any ideas what could go wrong? And btw, it seams the system supports utf-8 encoding...

[root@u16641744 01]# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

ls result in a directory containing such files:

-rw-r--r-- 1 user group   6093 Dec 22 17:39 Adoración-de-los-Magos-Botticelli-110x90.jpg

But the curios thing is that the output of the following command, is wrong:

perl -Mcharnames=:full -CS -wle 'print "\N{EURO SIGN}"'
  |-> outputs: â¬
share|improve this question
    
Have you restarted apache? –  Anagio Dec 25 '12 at 16:48
    
@Anagio ... lol, of course :) –  w0rldart Dec 25 '12 at 16:54
    
Had to ask. Check out this question on StackOverflow stackoverflow.com/questions/913869/… –  Anagio Dec 26 '12 at 12:20
    
@Anagio no luck mate... I keep trying over and over again everything I can think of, no luck at all –  w0rldart Jan 7 '13 at 16:35
    
What does the errorlog say when you get an unexpected 404? Turn up the loglevel if necessary. –  user555 May 2 '13 at 23:37

1 Answer 1

up vote 1 down vote accepted

Just so you know folks, I ended up re-installing the system. I would definitely say that the issue was from the host provider with its default install.

So yea, after hours and hours of trying to debug and fix this (I tried Apache tweaking, System encoding, File system checks, ...) ended up finally just installing a

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.