Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I recently enabled CloudFlare on my domain, and when I make HTML statements like this:

<link href="css/main.css" rel="stylesheet" />

The CSS gets displayed in-line, like this:

<style>body{padding-top:40px}span.light{font-weight:lighter!important}span.title{font-size:60px;line-height:1;letter-spacing:-1px;color:inherit}</style>

When I update the file via FTP, the changes are not reflected, which leads me to believe that this is a caching issue.

Is this due to CloudFlare? If so, how do I disable the behavior?

EDIT I also came to the conclusion that caching is behind the behavior after being able to see changes in the page after re-naming the CSS file.

share|improve this question
add comment

2 Answers 2

Manually purge the cache in CloudFlare

https://support.cloudflare.com/entries/22042092-how-do-i-purge-my-cache

share|improve this answer
    
Hmm... doesn't seem to have any effect. –  esqew Dec 7 '12 at 22:02
    
Are you running WordPress? –  Anagio Dec 7 '12 at 22:04
    
This has occurred in a separate WordPress install but it's also occurring in manually-generated pages. –  esqew Dec 7 '12 at 22:09
    
I'd contact CloudFlare if you're paying for their service their support can tell you exactly what's going on. –  Anagio Dec 7 '12 at 23:58
add comment
up vote 0 down vote accepted

I found that this wasn't a CloudFlare caching issue, it was caused by Google's mod_pagespeed enabled on my DreamHost account's configuration page.

The externally-referenced CSS files stopped appearing inline after disabling this addon.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.