Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Recently we implemented Varnish in front of our web nodes so that the backend would get some rest from time to time. Since varnish is case sensitive and our app was not we implemented a 301 in varnish to redirect to small case. Example:

You search for PlumBer StockHOLM you will get a 301 redirect to plumber stockholm and then plumber stockholm will be cached. This worked as a charm, but when checking the Google webmaster tools we suddenly got a crazy amount of Status - Not able to follow errors. As you can see in the image below:

not follow

This of course stirred up some panic and I started to read up on the documentation once again. If I pressed on one of the links I got to the help section where i found this: docs

Well this is strange, but as the day progressed more and more errors were thrown by Google. We took the decision to make varnish return 200 instead of the 301.

Now when testing the links that appears in the Not able to follow section I get a 200 back. I have tested with Chrome, curl and lynx reader and everything looks ok but the amount of errors are still increasing. What is a little bit comforting is that the links that appears in the Not able to follow section are dated before the 200 change in varnish. Why do I get these errors and why do they keep increasing? Did google release something new on October 31? Maybe I do not understand the docs correctly?

share|improve this question
    
Did you try fetching these pages as Googlebot using WMT? –  jeffatrackaid Nov 26 '12 at 22:00
    
Google gives you a list of these urls that have this error, correct? Try two additional tools that will let you see redirects better. Firefox with livehttpheaders extension and curl on the command line with the option: --dump-header <file> –  Stephen Ostermiller Jan 17 '13 at 15:11
add comment

1 Answer

You may want to check out: http://support.google.com/webmasters/bin/answer.py?hl=en&answer=1235687

Perhaps google bot is handling your parameters in a case insensitive manner, which would create a loop.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.