Webmasters Stack Exchange is a question and answer site for pro webmasters. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed MAMP on Mac OSX 10.8.2.

When it is started, I'm not able to access the server through http://localhost:8888 but when I visit and it works fine.

Why is it so? and how can I make it work with when I type http://localhost:8888

share|improve this question

Open your host file /etc/hosts with a text editor and make sure it contains:    localhost

If it still doesn't work, run this command: file -b /etc/hosts and make sure the result is ASCII English text and nothing else. If it is not, use an editor such as TextWrangler or BBEdit to clean it up (use Unix end-of-line characters).

Source: Apple Support Communities

share|improve this answer
I used Unix end-of-line and this solved my problem. – alexcristea Nov 22 '13 at 7:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.