Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have a blog http://foo.tumblr.com. I sometimes go to Site Content - All Pages on Google Analytics and then navigate to page listing and then click the icon to take me to that page on my blog. However, instead of opening http://foo.tumblr.com/post/1234/blah.html Google Analytics is opening http://foo.tumblr.com//post/1234/blah.html (i.e., it is adding a second slash between the domain the page specific component of the URL). How can I stop Google Analytics from doing this?

share|improve this question
add comment

6 Answers 6

This site has multiple solutions for the double slash http://sltaylor.co.uk/blog/double-slashes-in-analytics-urls/

share|improve this answer
add comment

In your Google Analytics, check under the Admin page, the Property settings for the site. In the default URL, perhaps you are leaving behind one more slash, take that out and GA will start showing the correct URLs from the day you make this change.

share|improve this answer
    
Thanks for the suggestion, but my default URL is like http://foo.tumblr.com. i.e., it is not http://foo.tumblr.com/. –  Jeromy Anglim Nov 5 '12 at 23:19
    
It seems that the URL was fine on the property settings page, but there was an extra slash on the profile settings page. –  Jeromy Anglim Nov 5 '12 at 23:57
add comment

You have a slash on the end of your website URI configuration profile.

share|improve this answer
add comment

Remove the trailing slashes from your site name in Google Analytics on your admin page.

share|improve this answer
add comment

Several people mention removing the trailing slash in the website URL in Google Analytics. I had checked my website "property settings" and there was no trailing slash in the website URL.

However, there is a separate "profile settings" page which did have a trailing slash. When I removed the slash from this page, the problem was fixed.

share|improve this answer
add comment

This is now in Admin -> "View Settings" (right hand column) under "default page" with the new Analytics layout...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.