Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

We have set up on a VPS a WordPress blog. But, after we work a while, if we leave the tabs open in our browsers, there is upload traffic, in small chunks but quite often. We thought that it might be the WordPress's AutoSave feature, but we disabled it and the thing still continues. Here you have a small snippet from the log (the real domain URL replaced):

[06/Oct/2010:12:41:06] "CONNECT connect://fooURL.com:443/" 0 53692 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:07] "CONNECT connect://fooURL.com:443/" 0 2925 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:07] "CONNECT connect://fooURL.com:443/" 0 24279 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:08] "CONNECT connect://fooURL.com:443/" 0 2301 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:08] "CONNECT connect://fooURL.com:443/" 0 2269 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:09] "CONNECT connect://fooURL.com:443/" 0 37459 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:09] "CONNECT connect://fooURL.com:443/" 0 6220 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:09] "CONNECT connect://fooURL.com:443/" 0 4140 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:09] "CONNECT connect://fooURL.com:443/" 0 16508 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:09] "CONNECT connect://fooURL.com:443/" 0 5148 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:41:09] "CONNECT connect://fooURL.com:443/" 0 6268 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:43:03] "CONNECT connect://fooURL.com:443/" 0 34056 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:43:03] "CONNECT connect://fooURL.com:443/" 0 42002 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:43:30] "CONNECT connect://fooURL.com:443/" 0 2381 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable
[06/Oct/2010:12:43:31] "CONNECT connect://fooURL.com:443/" 0 8775 "-" "Opera/9.80 (X11; Linux i686; U; en) Presto/2.6.30 Version/10.62" - "- -" "clean-sites,CONNECT,uncachable

It is normal? If not, why? How can we get rid of it?

share|improve this question
1  
I do not know if this is normal behaviour for your version of Opera with your version of server/Wordpress (but such details would be helpful), however this looks like persistent connections are dropping off. Increasing the length of time persistent connections last for may remove log entries, BUT could seriously limit the scalability of your server (hence this is a comment, not an answer). –  Metalshark Oct 7 '10 at 5:15
    
Does this happen with browsers other than Opera? –  Tim Fountain Oct 7 '10 at 8:29
    
@Tim: Yes, it happens with other browsers - it seems/seemed that Firefox is more prone to this. –  John Thomas Oct 7 '10 at 9:28
    
@Metalshark: So, IIUC this could be a better situation rather than having a, let's say, a "cleaner" log. Also, perhaps this could be because we are on a wiereless (AFAIK) connection, known for its latency? –  John Thomas Oct 7 '10 at 9:32
1  
Unfortunately better depends on your perspective. If you filter just those messages you won't be able to see when there is a problem (DDoS attacks, etc). DisgruntledGoat has hit the nail on the head with regards to a proper way to diagnose, which I would personally follow before considering log filtering. It should be possible to adjust the Ajax polling rate when using SSL, or see if anyone has a patch to use multi-part GET, thus keeping the connection alive and reducing the log messages drastically. –  Metalshark Oct 8 '10 at 18:51
show 1 more comment

1 Answer 1

up vote 3 down vote accepted

You should be able to find out using the Firebug console in Firefox. Enable the console then open the page in question. You should see some lines like this appearing:

POST http://example/wp-admin/admin-ajax.php  200 OK  594ms
POST http://example/wp-admin/admin-ajax.php  200 OK  882ms

On my copy of WP it only appears to be the auto save function but perhaps there is a particular setting or plugin that's doing something else in your case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.