Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

We host several websites on the same server using WHM but this seems to confuse the mail routing when someone has their own external mail servers - it looks locally.

We have our own email accounts hosted on the server. When creating an account for a client on the same server WHM adds the default entries to the DNS for that account. However this client has their own mail servers elsewhere. But when sending them an email it never reaches that external server - it just sees the local, incorrect one.

I realise I can update my DNS to point to the external server, but this means I am copying their settings and if they are changed, then I will also need to update mine.

Are there some settings I can use to force it to use the external servers without having to copy the settings.

share|improve this question
add comment

1 Answer

If the user's email is hosted on an system external to WHM, you need to set the mail exchange setting to remote.

You can do this in two areas.

1) Domain level. Look for the MX entry icon under the mail section.

http://awesomescreenshot.com/054i5ptba

2) WHM level.
Look for the Edit MX Entry link on the left.

For local domains, you can just leave this to auto-detect.

For remote domains, I recommend you set it to Remote Mail Exchanger.

Changing your DNS will not help as DNS is not consulted for a local domain.

share|improve this answer
    
I'm sure I've tried that but with no success. I will try it again next time I have the problem though. –  Richard Le Poidevin Oct 5 '12 at 7:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.