Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

When I plug my web page into Google's Rich Snippet Testing Tool it grabs all of the schema.org info I've plugged in correctly, but it says it doesn't detect any structured data when I click on the structured data dashboard. Is the dashboard buggy still, being so new or is it possible I'm doing something wrong?

share|improve this question
1  
How long have your live site web pages had the rich snippet markups? The GWT dashboard won't show anything until googlebot has processed the live pages. –  mgkrebbs Sep 8 '12 at 4:31
    
Well, the pages are indexed now but I added the rich snippets to the pages after initially submitting them to google and cannot remember if I resubmitted them. I'll resubmit them and see what happens in about a week. –  huzzah Sep 14 '12 at 15:52
    
I am facing the same problem with my site. Still doesn't detect any of the structured data.. Its been 4 days now.. –  user19100 Oct 13 '12 at 5:17
    
@Joseph, don't start panicking unless it has been well over a week. I gave it two weeks to be on the safe side. –  huzzah Oct 15 '12 at 19:46
add comment

1 Answer

up vote 4 down vote accepted

In my experience, changes to microdata have often taken a week or more to show up in GWT, even after manually re-submitting affected pages. Assuming the Testing Tool reports correctly functioning code, I wouldn't worry; GWT will show it eventually.

share|improve this answer
1  
You guys are correct. It just took GWT awhile. Thanks! –  huzzah Sep 20 '12 at 16:35
1  
@huzzah Cool! Worth knowing others are getting the same experience. –  GDav Sep 20 '12 at 16:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.