Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am pulling my hair out after multiple back and forths with 1and1 support both via email and telephone.

I've setup multiple subdomains via the 1and1 control panel and that looks to work fine. The one in the screenshot below is

http://x3.keefermadness.com

Everything loads properly except images. Inspecting them, they're giving a 403 Forbidden. I've tried changing the permissions on individual files and the directories in that structure to no avail.

1and1 keeps blaming it on my image references, but they work fine locally via MAMP with no changes to anything.

Any ideas? 1and1 has been completely worthless, and I'm very close to just moving to another web host.

I've tried other web content, including a clean wordpress install. No images ever load. Everything else - html, JS, CSS, loads fine.

403 forbidden

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I just looked at your page source, and (example) image: http://x3.keefermadness.com/lib/img/home/home-about.jpg loads perfectly fine by visiting that URL. Do you have a setting enabled for "disallow hotlinking" of images somewhere? It is possible that that could be causing the problem.

share|improve this answer
    
Crap! Good call. In the root of the domain, I had these rules: RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?keefermadness.com [NC] # RewriteRule \.(jpg|jpeg|png|gif)$ - [NC,F,L] –  Keefer Aug 26 '12 at 18:38
add comment

We removed the last line on the .htaccess file

RewriteEngine on 
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?zzz\.com [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?zzz\.co.uk [NC]
RewriteRule \.(gif|jpe?g|js|css|png)$ - [F,NC,L]

which was returning the forbidden action for images and CSS

RewriteEngine on 
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?zzz\.com [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?zzz\.co.uk [NC]

https://httpd.apache.org/docs/2.2/rewrite/flags.html#flag_f

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.