Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

The site is www.books-for-children.com, developed in Wordpress CMS. It was launched about two months ago and still has not been cached by Google, which seems highly unusual. Any ideas where I might look for answers?

share|improve this question
1  
We need some more information than that - have you submitted a valid sitemap to Google? Do you have an Analytics or Webmaster Tools account? –  Christopher Aug 17 '12 at 5:19
add comment

4 Answers 4

Because you told them not to(see under "Controlling Caching and Snippets"):

<meta name="robots" content="noodp,noydir,noarchive,nosnippet"/>

...along with several other things not to do.

As to why that is, you'll have to inspect your WordPress installation(settings, SEO plugins) and theme files to figure out exactly where that tag's coming from, but it looks like the Yoast plugin is doing it.

share|improve this answer
add comment

Additional from what Su' said, this is from the Google FAQ:

Q: My site isn't indexed yet!

A: Crawling and indexing are processes which can take some time and which rely on many factors. In general, we cannot make predictions or guarantees about when or if your URLs will be crawled or indexed. When looking at a site's indexing in Webmaster Tools, make sure that you have both the "www" and the "non-www" versions (like "www.example.com" and "example.com") verified and have a set a preferred domain. Keep in mind that while a Sitemap file can help us learn about your site, it does not guarantee indexing or increase your site's ranking.

share|improve this answer
add comment

You Try to do this.

Open the Wordpress admin then go to Setting=> Privacy =>Allow search engines to index this site => Save..

It Caches Wordpress Sites.

share|improve this answer
add comment

You can suggest your site in Googles Webmaster tools. Maybe that will help.

share|improve this answer
    
Which means, you need to generate a sitemap.xml within Wordpress. There are plugins that do that for you. Also check if you have blocked out search engines from within your admin dashboard. Check under "Settings" -> "Privacy" and make sure "Allow search engines to index this site." is checked. –  DKOATED Oct 6 '12 at 12:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.