Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am creating a local HTML file that links to 2 external CSS files and 3 external JS files.

When I refresh this in Internet Explorer 9, the page takes over a minute to load compared to instantly in Firefox (latest stable build. When I remove the external CSS and JS references, IE9 loads the page instantly.

Can anyone explain why IE9 takes so long to load local HTML files with references to external CSS and JS files?

share|improve this question
    
Have you verified the same symptoms with a different machine? I suspect it's caching settings - FireFox could have the CSS/JS files cached and IE9 is set to not cache (Which is an HTTPRequest every time for every file). –  Christopher Aug 17 '12 at 5:17
2  
It's basically impossible to say unless we have some kind of test page or details on what exactly the external files are. –  DisgruntledGoat Aug 17 '12 at 8:14
    
Are these files external to your page, but still local to your system? Or are they external in terms of being located on another server far far away? –  w3d Aug 17 '12 at 9:44
add comment

closed as too localized by Su', paulmorriss Feb 8 '13 at 14:51

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

up vote 2 down vote accepted

Depending on which version of IE you're using, you may see a message like this when you run a webpage locally - "Internet Explorer has restricted this webpage from running scripts or ActiveX controls"

An oversimplified answer is that there is security check that happens due to the zone the web page runs in. Read the nitty gritty here.

You can override the check by serving content from a web server or adding the Mark of the Web comment between the DOCTYPE and the HTML tag.

share|improve this answer
add comment

I agree with the comments. It could be cache settings and/or browser settings, and I will also add that it could be one or more add-ons slowing you down. I recommend clearing the cache, double checking all of your settings, and disabling any add-ons. You might also want to try reinstalling the browser, and rebooting your system.

It is also true that it's impossible to look for bugs if we can't duplicate the problem you're having. Unless we can see the behavior any answer we can offer would be pure speculation.

share|improve this answer
add comment

I have been suffering the same problem for a long time. Recently I found out it is because of a plugin call infoatoms, after uninstalling it, problem solved. Hope this helps.

share|improve this answer
    
I do not have that plugin installed, thanks for the response though. –  rlsaj Feb 6 '13 at 19:24
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.