Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

this is my first time using Nginx or phppgAdmin, and after placing the phppgadmin folder into my public_html folder I find that the resources for the phppgadmin page are broken, images and css specifically. phppgAdmin runs and works with postgresql/php on my system, but without images or css it becomes difficult to use.

share|improve this question
    
What do you mean by "placing the phpPgAdmin folder in public_html?" Was it already installed someplace else and you just moved it over there? If so, did you update any relevant configuration that would tell the application where it lives? –  Su' Jul 13 '12 at 8:59
add comment

1 Answer

Having had a look at the configuration file (phpPgAdmin/conf/config.inc.php) I can't see any variables where you would need to tell it the web path it runs from, though initially it sounds like the images and CSS files are not working due to an incorrectly specified URL path.

Perhaps try to investigate further by viewing the page source while looking at your phppgAdmin page with the theme files not loaded properly, and look in the source code to see what URL's have been specified for CSS and images - try to load one or more of them by pasting the URL directly into your browser - this may reveal a clue. If the path is right, I suspect the file permissions are insufficient.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.