Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Have already seen suggests on how to rewrite https to http. currently using this technique :

RewriteCond %{SERVER_PORT} ^443$
RewriteRule ^(.*)$ http://www.mysite.com/$1 [L,R=301]
RewriteRule ^(.*)$ http ://%{HTTP_HOST}%{REQUEST_URI} [R=301,L] 

Problem : I am currently on Hostgator VPS and have found Google indexing my HTTPS pages. Weird for me as never bought an SSL. My site is a blog only. When spoke to Google forums, ( https://productforums.google.com/forum/#!msg/webmasters/2Hz46t44nwk/7voZWudFtAQJ ), they say I should redirect https to http. Now when I have redirected this using the above method, I am still getting SSL warning in browsers. And found that Google is still indexing my new pages with https.

I feel as I do not have an SSL, adding a redirect in https doesn't work. So if Google indexes my https page, then I should go and buy SSL, and tell there to redirect https to http. Why would I do that? Please help me, reduced the traffic by nearly 30% because of this.

Have even told search engines to go to this file (disallows everything) if they are on https.

Options +FollowSymlinks 
RewriteCond %{SERVER_PORT} ^443$ 
RewriteRule ^robots.txt$ robots_ssl.txt
share|improve this question
    
You will see such warning in browser when domain name in SSL certificate does not match requested domain name. Because SSL (S part of HTTPS) executes before http connection is made (before mod_rewrite has a change to kick in), you will see it (warning) unless you install correct certificate. You better find out why you are indexed via HTTPS (cannot help here, unfortunately) –  LazyOne Jun 11 '12 at 13:39
    
thanks. have consulted hostgator people and they say plesk automatically adds an ssl. any further solution? –  Akshay Jun 11 '12 at 13:59
    
Except disabling SSL (removing such binding) in Plesk -- nope, sorry. Maybe somebody else has better ideas -- I have never met such issue myself and don't really know where to start (except all what I have said already). –  LazyOne Jun 11 '12 at 14:17

2 Answers 2

Disable or remove SSL from Plesk ( http://support.hostgator.com/articles/ssl-certificates/ssl-setup-use/how-to-setup-and-use-a-shared-ssl-windows ), submit a clean sitemap to Google Webmaster Center. I would avoid creating redirects if you can solve this by disabling SSL and letting Google re-index your site properly.

share|improve this answer

Add the following meta tag in your HTTPS pages

<meta name="robots" content="noindex,nofollow">
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.