Webmasters Stack Exchange is a question and answer site for pro webmasters. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know of the potential risks.

The only "useful" thing I've been able to find after Google-ing is this, on the cPanel website, which has no context whatsoever.

Does anyone know how to do this?

My version of cPanel is 11.32.2 (build 28).

share|improve this question
up vote 1 down vote accepted

DB Prefixing is determined by the database_prefix value defined in /var/cpanel/cpanel.config.

  • • A value of “1” denotes that DB Prefixing is enabled and will emulate prefixing behavior prior to DB Mapping.

  • • A value of “0” denotes that DB Prefixing is disabled and all database resources created by cPanel accounts will be created literally as requested.

  • • The absence of a database_prefix definition will behave as if a value of “1” existed.

Manually modifying cpanel.config is HIGHLY DISCOURAGED and can produce unexpected behaviors. WHM provides the necessary UI for setting DB Prefixing to “0,” “Off” but forr Cpanel you have to do it manually .

PS :

Operating cPanel systems with Prefixing “Off” can introduce an artificially frequent occurrence of “name collision” when creating cPanel accounts and cpuser database resources. Because arbitrary names are allowed, the probability that common names are requested will increase and therefore the denial to use those names will also increase

share|improve this answer
That's fine. It's only me that has access to my website anyway. Do you happen to know how I gain access to the config file? I can't see the path through an FTP client. – mythofechelon Jun 4 '12 at 21:59
If you are using sharing hosting , you probably can't access it. the admin will not allow you to access config file. – panindra Jun 5 '12 at 3:00
Nevermind. Apparently my hosting plan doesn't include access to WHM or these settings. Thanks anyway, though. – mythofechelon Jun 5 '12 at 16:35

In WHM, there's a section of the menu called SQL Services.

Go into it, and then find: Disable Database Prefix.

This page has a screenshot of that screen: http://kb.iweb.com/entries/21073657-how-can-i-repair-my-databases

share|improve this answer
Edit: Nevermind. It didn't occur to me straight away that WHM is its own site. Thanks, I'll try that now. – mythofechelon Jun 4 '12 at 21:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.