Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have WordPress installed on a GoDaddy deluxe account. I'm using this account to host multiple sites and just map the domains to the folder: i.e. www.mysite.com/awesome would be www.awesomesite.com. This is transparent to the user.

When I setup wordpress I installed it to a folder www.mysite.com/wordpress. I have a domain www.thesite.com mapped to www.mysite.com/wordpress. When I go to www.thesite.com it looks perfect. As soon as I click on a link it switches the domain to www.msite.com/wordpress. Is there a way to change this behavior?

share|improve this question

migrated from stackoverflow.com Apr 20 '12 at 4:23

This question came from our site for professional and enthusiast programmers.

    
Instead of just down voting tell me the problem.. leave a comment... – David Nelson Apr 19 '12 at 20:42
up vote 2 down vote accepted

Go to Wordpress Admin site > Setting tab which is under the tools and update all the links there. Change it from

www.mysite.com/wordpress 

to

www.thesite.com 
share|improve this answer
    
Did that, but now when clicking on a link it gives me a 404 not found the URL it's trying to find is: www.thesite.com/wordpress – David Nelson Apr 19 '12 at 20:40
    
It might now work here but try to access it from www.thesite.com . It should work there. And obviously change it correctly. You may need to include Http://www.thesite.com – slow diver Apr 19 '12 at 20:42
1  
Yes, it actually was working, the problem was with the Home link in the menu trying to go to /wordpress instead of just / – David Nelson Apr 19 '12 at 20:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.