Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

My setup consists of:

  • a XAMPP 1.7.7 installation, with Apache configured to listen to port 8080
  • dyn.com to make the projects accessible from the web ( 8080 shows up as 'open' when checking with http://www.yougetsignal.com/tools/open-ports )
  • various PHP/Ajax/etc projects stored in folders inside xampp/htdocs. Ex: xampp/htdocs/crypt
  • the xampp folder, phpMyAdmin and MySQL are password-protected

When trying to access any of the projects using dyn.dns URLs ( http://mydomain.dyndns-ip.com/crypt ), I get a web page with something like

Object Not Found
The requested URL '/crypt' was not found on the RomPager server.

Adding the port number ( http://mydomain.dyndns-ip.com:8080/crypt ) will result in "The connection has timed out" pages. However, all the projects work when loaded with a localhost URL ( http://localhost:8080/crypt/ ).

Other issues:

  • accessing the root dyn.com URL asks me to log in to my router
  • when clicking the "Admin" button for Apache on the XAMPP control panel, it opens http://localhost/xampp/ - instead of http://localhost:8080/xampp/

I think this might have something to do with password-protecting the xampp folder, but there doesn't seem to any automatic way of "undo"-ing the security changes, and I don't know how to do that manually. Any pointers in troubleshooting this issue would be appreciated.

share|improve this question
    
RomPager is an embeddable web server used in your router - so there is a misconfiguration that is returning your router admin by default. –  adam Nov 27 '12 at 15:09

1 Answer 1

Often, port 8080 is the remote management port for your router. If you're getting a router login page when you go to your Dyn hostname, I'd suggest changing either the remote management port or the port your webserver runs on.

Also, AFAIK Dyn doesn't do port forwarding so accessing http://mydomain.dyndns-ip.com/crypt will use port 80.

Why not host your webserver on 80?

share|improve this answer
    
strangely enough, remote management is not enabled; the settings the same as in this picture, I shouldn't be able to even see the router config pages. WAN Management (TR-069) was enabled, however; but disabling it doesn't change anything. –  Mihai Rotaru Apr 19 '12 at 10:24
    
I also tried changing the port to 80. I didn't get a timeout, as with 8080, but instead received the "URL was not found on the RomPager server" error page. I also noticed the port not displayed in the address bar, probably because it's the default anyway. –  Mihai Rotaru Apr 19 '12 at 10:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.