Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I am trying to enable the internal site seach tracking with Google Analytics.

So at analytics page, account mysite.com: Profile Settings => Site Search Settings, do track enabled.

At my site when someone make a search for test, URL looks like: mysite.com/search?keyword=test. At the query parameter I added search?keyword= but I haven't seen any results so far, any idea how to fix this?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

If the search result page is at mysite.com/search?keyword=test, then the query parameter is keyword

share|improve this answer
    
Thanks you! After i made the changes, it was a matter of time since i started search tracking :) –  HaCos Apr 5 '12 at 14:59
add comment

Tracking Custom Search Engine results in Google Analytics

  1. Access your Custom Search Engine by either signing in to your Google Account used for creating the CSE or by visiting http://www.google.com/coop/manage/cse/. Then select Control Panel for the Search Engine you wish to track.
  2. Click Look and feel.
  3. Select a layout and style.
  4. Click Save & Get Code.
  5. Select the check box for Include Google Analytics Site Search tracking code.
  6. Under Specify your Google Analytics Site Search account id, enter your Google Analytics ID.
  7. Under Specify your Google Analytics Site Search query parameter name, enter the query parameter you want to use.
  8. Include the Google Analytics Tracking Code on the page where you'd like the Custom Search element to appear. Read How do I add tracking code to my website? for more details.

http://support.google.com/googleanalytics/bin/answer.py?hl=en&answer=98222

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.