Take the 2-minute tour ×
Webmasters Stack Exchange is a question and answer site for pro webmasters. It's 100% free, no registration required.

I have <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> and <meta name="google" value="notranslate"> but tries to translate the page.

share|improve this question

1 Answer 1

I'm afraid you have misunderstood the function of the tag.

<meta name="google" value="notranslate">

only prevents google from showing the 'translate this page option' in their search results, it has no effect on Chrome's translation functionality.

If you specify the page language correctly, Chrome won't offer to translate the page for users with the same browser language setting.

<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

Forces the use of the latest IE rendering engine and Chrome Frame (even in an intranet) and has no effect on translation.

share|improve this answer
    
Yes, I want it to prevent Google frame from showing the "translate this page". The language is specified correctly both by header and meta. Yes, I want it to use Google Frame because Trident is crap. –  ilhan Mar 21 '12 at 16:02
1  
@george It's the browser, there doesn't appear to be anything you can do to stop it. –  MJWadmin Mar 21 '12 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.